Modify

Opened 6 years ago

Last modified 4 years ago

#9994 reopened defect

TP-LINK TL-WR741ND dont work external antenna

Reported by: bebebe@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Openwrt Backfire RC5. Two routers TL-WR741ND with Dlink 14dB antennas are not connected, but each sees the router adjacent AP. If I change the TL-WR741ND to DLINK G700 and a connection is established. How to configure the antenna selection on openwrt rc5 or disable built-in antenna?

Attachments (0)

Change History (6)

comment:2 Changed 6 years ago by bebebe@…

I filled the firmware from TP-LINK 743ND and everything worked, then the problem is in the driver ath9k. Fix it, please.

comment:3 Changed 6 years ago by bebebe@…

comment:4 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

as of trunk r28107 you can now set the rx antenna properly. to use only the external antenna on tl-wr741nd, put 'option txantenna 1' and 'option rxantenna 1' in the wifi-device section in /etc/config/wireless

comment:5 Changed 6 years ago by epek

  • Resolution fixed deleted
  • Status changed from closed to reopened

The problem is probably existing again for hardware revision 4.
While using a directional antenna, I see high noise levels (-91dbm) and low overall signal levels.
txantenna, rxantenna (and diversity - even if nonsense) won't show significant changes in reception. Far stations won't receive the signal, as opposed to an other router on low txpower.

iw phy phy0 info | grep -i ant

Report 0x1 both for configured and possible antennas. This value does currently never change.

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.