Modify

Opened 6 years ago

Closed 3 years ago

#9993 closed defect (moved_to_github)

collectd-mod-rrdtool segfaults when trying to generate iptables graphs

Reported by: aztunwein@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Backfire 10.03.1 RC5
Keywords: collectd Cc:

Description

After installing collectd, collectd-mod-rrd and luci-app-statistics I was getting this error:

collectd[11946]: segfault at 1 ip b7752ae9 sp bf3ff65c error 4 in libuClibc-0.9.30.1.so[b772a000+46000]

After reading this post I disabled the iptables statistics:
https://forum.openwrt.org/viewtopic.php?pid=141985#p141985

but as I have collectd rrd files saved in an external permanent storage I was still getting the same segfaults. Once deleted the iptables rrd files I don´t get segfault so I think the problem is when collectd-mod-rrd tries to generate graphs from iptables rrd files.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

comment:2 Changed 3 years ago by nbd

  • Resolution set to moved_to_github
  • Status changed from new to closed

collectd is maintained here: https://github.com/openwrt/packages

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.