Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#9928 closed defect (fixed)

usb_wwan unknown symbol on kernel 3.0.1

Reported by: dcheng Owned by: hauke
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: usb_wwan option wgt634u Cc:

Description

device: netgear wgt634u
arch: brcm47xx

I got these errors on boot after updating to trunk r27950 with kernel 3.0.1.

usb_wwan: Unknown symbol usb_serial_port_softint (err 0)
option: Unknown symbol usb_wwan_write (err 0)
option: Unknown symbol usb_wwan_close (err 0)
option: Unknown symbol usb_wwan_release (err 0)
option: Unknown symbol usb_serial_disconnect (err 0)
option: Unknown symbol usb_wwan_tiocmget (err 0)
option: Unknown symbol usb_wwan_chars_in_buffer (err 0)
option: Unknown symbol usb_wwan_write_room (err 0)
option: Unknown symbol usb_wwan_disconnect (err 0)
option: Unknown symbol usb_wwan_startup (err 0)
option: Unknown symbol usb_wwan_set_termios (err 0)
option: Unknown symbol usb_wwan_dtr_rts (err 0)
option: Unknown symbol usb_wwan_open (err 0)
option: Unknown symbol usb_serial_probe (err 0)
option: Unknown symbol usb_serial_register (err 0)
option: Unknown symbol usb_serial_deregister (err 0)
option: Unknown symbol usb_wwan_ioctl (err 0)
option: Unknown symbol usb_wwan_tiocmset (err 0)

An older build (trunk r27760, kernel 2.6.39.2) had no such problems.

Attachments (0)

Change History (6)

comment:1 follow-up: Changed 6 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to assigned

I am unable to reproduce this. Do you get any more error messages? Was usbserial loaded successfully?

comment:2 in reply to: ↑ 1 ; follow-up: Changed 6 years ago by dcheng

No, usbserial was not loaded. I checked the boot log and found

uhci_hcd: USB Universal Host Controller Interface driver
usbserial: Unknown parameter `maxSize'
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb_wwan: Unknown symbol usb_serial_port_softint (err 0)
...

Was the parameter maxSize causing problem?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 6 years ago by jogo

Replying to dcheng:

No, usbserial was not loaded. I checked the boot log and found

uhci_hcd: USB Universal Host Controller Interface driver
usbserial: Unknown parameter `maxSize'
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb_wwan: Unknown symbol usb_serial_port_softint (err 0)
...

Was the parameter maxSize causing problem?

Quite likely, it was recently removed since the issue it was working around got fixed in the actual driver several years ago.

Try removing it.

comment:4 in reply to: ↑ 3 Changed 6 years ago by dcheng

Removing maxSize from /etc/modules.d/60-usb-serial had solved the problem for me. My 3g dongle was recognized and working again. Thanks for your help.

comment:5 Changed 6 years ago by hauke

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.