Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9865 closed defect (fixed)

Trunk does not compile

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: toolchain Version: Trunk
Keywords: TARGET, gcc-linaro, set_default_bfd_target, toolchain-mipsel_gcc-linaro_uClibc-0.9.32, bucomm, bucomm.c Cc:

Description (last modified by hauke)

Current trunk (27862) does not compile.

BUILD ENVIROMENT:
System: OpenSuse 11.4, gcc 4.5.1 (11.3 / gcc4.6 were also tested)

gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib64/gcc/x86_64-suse-linux/4.5/lto-wrapper
Target: x86_64-suse-linux
Configured with: ../configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.5 --enable-ssp --disable-libssp --disable-plugin --with-bugurl=http://bugs.opensuse.org/ --with-pkgversion='SUSE Linux' --disable-libgcj --disable-libmudflap --with-slibdir=/lib64 --with-system-zlib --enable-__cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --enable-version-specific-runtime-libs --program-suffix=-4.5 --enable-linux-futex --without-system-libunwind --enable-gold --with-plugin-ld=/usr/bin/gold --with-arch-32=i586 --with-tune=generic --build=x86_64-suse-linux
Thread model: posix
gcc version 4.5.1 20101208 [gcc-4_5-branch revision 167585] (SUSE Linux)

STEPS TO REPRODUCE:

cd trunk
make clean
make distclean
svn up
./scripts/feeds/update -a
./scripts/feeds/install -a
make -j 4 V=99

make[8]: Entering directory `/mnt/data1/openwrt/trunk/build_dir/toolchain-mipsel_gcc-linaro_uClibc-0.9.32/binutils-2.20.1/binutils'
gcc -DHAVE_CONFIG_H -I.  -I. -I. -I../bfd -I./../bfd -I./../include -DLOCALEDIR="\"/mnt/data1/openwrt/trunk/staging_dir/toolchain-mipsel_gcc-linaro_uClibc-0.9.32/share/locale\"" -Dbin_dummy_emulation=bin_vanilla_emulation  -W -Wall -Wstrict-prototypes -Wmissing-prototypes  -MT bucomm.o -MD -MP -MF .deps/bucomm.Tpo -c -o bucomm.o bucomm.c
bucomm.c: In function 'set_default_bfd_target':
bucomm.c:154:24: error: 'TARGET' undeclared (first use in this function)
bucomm.c:154:24: note: each undeclared identifier is reported only once for each function it appears in
make[8]: *** [bucomm.o] Error 1

Attachments (0)

Change History (7)

comment:1 Changed 7 years ago by anonymous

I'm sorry for formatting, something went wrong after submitting ticket

comment:2 Changed 7 years ago by mazilo

To compile OpenWRT from source, the source needs be configured first. You had issued make distclean to remove everything (including .config file), except the source. As such, you will first need to run make menuconfig to select the platform and/or among other packages before you can do a make to compile.

comment:3 Changed 7 years ago by anonymous

Of course sources were configured before "make" (forgot to write in ticket description).
"make distclean" was performed to assure that there was not any garbage. And it does not work on OpenSuse.

comment:4 Changed 7 years ago by hauke

  • Description modified (diff)

comment:5 Changed 6 years ago by anonymous

I found out, that the problem was about that $C_INCLUDE_PATH system variable was set. If it is set, gcc-linaro will not compile. Workaround is to unset $C_INCLUDE_PATH, however the problem should be somewhere in makefiles.
Regards.

comment:6 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r30830

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.