Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9822 closed defect (fixed)

Assert error in /luci/controller/luci_diag/devinfo_common.lua

Reported by: hnyman Owned by:
Priority: high Milestone: Barrier Breaker 14.07
Component: luci Version: Trunk
Keywords: Cc: hannu.nyman@…

Description

Since July 25th, my ar71xx/WNDR3700 Openwrt trunk builds (r27771, r27787, r27797) lock me totally out of the Luci GUI. The browser (both IE and Firefox) session gets stuck to an assert error before password prompt in Luci.

/usr/lib/lua/luci/dispatcher.lua:492: Invalid controller file found
The file '/usr/lib/lua/luci/controller/luci_diag/devinfo_common.lua' contains no index() function.
Please make sure that the controller contains a valid index function and verify the spelling!
stack traceback:
    [C]: in function 'assert'
    /usr/lib/lua/luci/dispatcher.lua:492: in function 'createindex_plain'
    /usr/lib/lua/luci/dispatcher.lua:420: in function 'createindex'
    /usr/lib/lua/luci/dispatcher.lua:512: in function 'createtree'
    /usr/lib/lua/luci/dispatcher.lua:182: in function 'dispatch'
    /usr/lib/lua/luci/dispatcher.lua:146: in function </usr/lib/lua/luci/dispatcher.lua:145>

Only console works.

That assertion error message seems to have been recently introduced with Luci 7325 http://luci.subsignal.org/trac/changeset/7325 . (Previous trunk build r27711 from July 20th works ok)

Openwrt built with dirclean, whole Luci source re-pulled with SVN from server. Flash without settings, so it should be a clean slate.

It might be that the new assertion error revealed some old flaw in Luci source regarding modules luci-app-diag-core, luci-app-diag-devinfo. The referenced file, devinfo_common.lua ( http://luci.subsignal.org/trac/browser/luci/trunk/applications/luci-diag-devinfo/luasrc/controller/luci_diag/devinfo_common.lua ), is rather old, so probably this new assertion just brings something out.

My Backfire build with Luci 0.10 works just normally.

Based on the forum discussion, there is now at least one other user with the same assert error:
https://forum.openwrt.org/viewtopic.php?id=31079

(I already filed this two days ago to the Luci bug tracker, but it seems to have got stuck in the moderation queue.)

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by anonymous

#9825 is a new duplicate of this issue.

And copied from forum: https://forum.openwrt.org/viewtopic.php?pid=140155#p140155
"Yes, it is failing in luci-app-diag-devinfo package. I removed it via menuconfig, rebuilt and without it luci starts as usual."

comment:2 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.