Modify

Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#9818 closed defect (wontfix)

very weird disk usage on r27448

Reported by: Leonardo Rodrigues Magalhães <leonardormagalhaes@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: yaffs2 stange disk usage Cc:

Description

i'm experiencing VERY weird disk usage on recent trunks, which i didnt experienced on somehow older ones

on a r27448 trunk box, i have ....

root@obradatacenter:/# du * -s | sort -n
0       config
0       dev
0       proc
0       sys
1       lost+found
1       mnt
1       overlay
1       rom
1       var
11      root
52      tmp
182     sbin
477     www
969     etc
1286    bin
1431    lib
1737    backup
5380    squid
16580   usr

summing this, i have

root@obradatacenter:/# expr 1 + 1 + 1 + 1 + 1 + 11 + 52 + 182 + 477 + 969 + 1286 + 1431 + 1737 + 5380 + 16580
28110
root@obradatacenter:/#

but df usage shows VERY different numbers

root@obradatacenter:~# df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                59392     57776      1616  97% /
tmpfs                    30956        48     30908   0% /tmp
tmpfs                      512         0       512   0% /dev
root@obradatacenter:~#

28810 summing du usages and df shows 57776 usage

on a somehow old trunk, r20143 in my case, i have VERY close numbers to du sum and df:

root@sede:/# du * -s | sort -n
0       dev
0       proc
0       sys
1       home
1       lost+found
1       mnt
1       overlay
1       rom
1       var
9       root
56      tmp
111     sbin
477     www
1087    etc
1404    lib
1408    bin
1704    backup
9573    squid
17091   usr
root@sede:/#

summing the values from du

root@sede:/# expr 1 + 1 + 1 + 1 + 1 + 1 + 9 + 56 + 111 + 477 + 1087 + 1404 + 1408 + 1704 + 9573 + 17091
32926
root@sede:/#

and df shows

root@sede:/# df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                59392     33352     26040  56% /
tmpfs                    31064        56     31008   0% /tmp
tmpfs                      512         0       512   0% /dev
root@sede:/#

32926 summing du usages and 33352 displayed dy df

OK, not EXACT the same disk usage, but close enough to look OK, as i have used different methods to calculate disk usage, VERY different from what i'm getting on r27448.

why is this happening ???

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by Leonardo Rodrigues Magalhães <leonardormagalhaes@…>

forgot to mention, dont know if it matters ... the two boxes used to provide information below are Routerboard 450.

comment:2 Changed 7 years ago by Leonardo Rodrigues Magalhães <leonardormagalhaes@…>

hello guys ... no news on this ?

comment:3 Changed 5 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

it's not a bug, the filesystem has some overhead as well, sometimes blocks can be freed up, but are still used by some data.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.