Modify

Opened 7 years ago

Closed 7 years ago

#9782 closed defect (fixed)

no "option device ..." for new VLAN in network config over LuCI

Reported by: anonymous Owned by:
Priority: normal Milestone: Backfire 10.03.1
Component: luci Version: Backfire 10.03.1 RC5
Keywords: VLAN Cc:

Description

I've created a new VLNAN over LuCI on my WNDR3700v2 and nuthing worked. Finally found the problem in /etc/config/network in the switch_vlan config of the new VLAN where the line "option device rtl8366s" was missing. It seems LuCI doesn't add this line.

After adding this line everything worked fine.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with http://luci.subsignal.org/trac/changeset/7330 and http://luci.subsignal.org/trac/changeset/7331 .

You can patch it on the router by issuing the command below.

wget -qO /usr/lib/lua/luci/model/cbi/admin_network/vlan.lua http://luci.subsignal.org/trac/export/7331/luci/branches/luci-0.10/modules/admin-full/luasrc/model/cbi/admin_network/vlan.lua

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.