Modify

Opened 7 years ago

Last modified 4 years ago

#9772 accepted defect

ar525w rdc kernel will not decompress

Reported by: anonymous Owned by: florian
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Backfire 10.03.1 RC5
Keywords: Cc:

Description

RedBoot> C
RedBoot> tftpd
# Dante's tiny tftpd is ready......
WRequest from 192.168.1.2: [openwrt-rdc-squashfs-ar525w.img, octet]

# Firmware Checksum O.K
# DFLASH: SRC=0x00400000, DST=0xFFC00000, LEN=0x00200004
# Decide to use AMD/Fujitsu Standard command set.
# MFG ID = 0x007F, DEV ID = 0x22F9
Flash size = 4 MB
# Erasing........................................
# Writing........................................
# Finishing successfully...
# Firmware Upgrade Finished, and shotdown the TFTPD......
RedBoot> reset
... Resetting.+Ethernet eth0: MAC address 00:00:01:02:03:04
IP: 192.168.1.1/255.255.255.0, Gateway: 192.168.1.254
Default server: 0.0.0.0

RedBoot(tm) bootstrap and debug environment [ROM]
Non-certified release, version v2_0 - built 18:31:11, Aug 4 2005

Platform: PC (I386)
Copyright (C) 2000, 2001, 2002, Red Hat, Inc.

RAM: 0x00000000-0x000f0000, 0x00072ed0-0x000a0000 available
ver 00:0003 05-24-05

<press Ctrl+C to enter prompt mode>

# Activate RDC-Keilven's RS232 Patch V2
RedBoot>
# Kernel size = 797280 bytes
# FW size = 2097156 bytes

# fwcheck: base = 0x00400000, size = 0x00000400
# Firmware Checksum O.K
# Kernel copying......BEGIN
# Kernel copying......FINISH

mem_size: 1000000

I've tried all of the backfire versions and the recent snapshot. Non of them work.

Attachments (1)

rdc.config (62.6 KB) - added by rwoodsmall <rwoodsmall@…> 6 years ago.
RDC .config attached. Not much changed from the default. Building on a Scientific Linux 6 box.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 7 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to accepted

This is because the kernel size exceeds 768KB, I will take a look into this.

comment:2 Changed 6 years ago by keithcampbell03@…

Can any drivers in this kernel be moved to modules? Any bloat built into the kernel? I have the same issue on my board, and would love to see this resolved if possible.

comment:3 Changed 6 years ago by florian

I think most of what can be loaded as a module already is, will see what more can be done.

comment:4 Changed 6 years ago by florian

Making bridge and 8021q support available as modules makes the kernel be smaller than 768KB, I will be testing this a bit more and commit the fix.

comment:5 Changed 6 years ago by florian

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed with r29028.

comment:6 Changed 6 years ago by rwoodsmall <rwoodsmall@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened

Attempting to boot my AR525W with 10.03.1 (rc5, rc6, release) fails in the same manner as above. A custom build also fails, shown below, simply hanging before the kernel gets uncompressed.

# Dante's tiny tftpd is ready......
WRequest from 192.168.1.63: [openwrt-rdc-squashfs-ar525w.img, octet]

# Firmware Checksum O.K
# DFLASH: SRC=0x00400000, DST=0xFFC00000, LEN=0x00200004
# Decide to use AMD/Fujitsu Standard command set.
# MFG ID = 0x007F, DEV ID = 0x22F6
Flash size = 4 MB
# Erasing.................................
# Writing.................................
# Finishing successfully...
# Firmware Upgrade Finished, and shotdown the TFTPD......
RedBoot> reset
... Resetting.+Ethernet eth0: MAC address 00:00:01:02:03:04
IP: 192.168.1.1/255.255.255.0, Gateway: 192.168.1.254
Default server: 0.0.0.0

RedBoot(tm) bootstrap and debug environment [ROM]
Non-certified release, version v2_0 - built 18:31:11, Aug  4 2005

Platform: PC (I386)
Copyright (C) 2000, 2001, 2002, Red Hat, Inc.

RAM: 0x00000000-0x000f0000, 0x00072ed0-0x000a0000 available
ver 00:0003  05-24-05

<press Ctrl+C to enter prompt mode>

# Activate RDC-Keilven's RS232 Patch V2
RedBoot>
# Kernel size = 750048 bytes
# FW size = 2097156 bytes

# fwcheck: base = 0x00400000, size = 0x00000400
# Firmware Checksum O.K
# Kernel copying......BEGIN
# Kernel copying......FINISH

mem_size: 1000000

I'd be fine with running 8.09.2 on this board, but the ethernet is still flaky on that release, and I'm having trouble finding/integrating a non-flaky r6040.c driver on a kernel of that vintage. Any advice? I have a build system setup so I can test trunk builds. -r

comment:7 Changed 6 years ago by florian

  • Status changed from reopened to accepted

I can't reproduce that error on my devices with official builds, can you post your .config?

Changed 6 years ago by rwoodsmall <rwoodsmall@…>

RDC .config attached. Not much changed from the default. Building on a Scientific Linux 6 box.

comment:8 Changed 6 years ago by basix86

I have tested on my Linksys WRT54GR, the backfire 10.03.1 file openwrt-rdc-jffs2-64k-ar525w.img, and i have the same issue.

RedBoot(tm) bootstrap and debug environment [ROM]                               
Non-certified release, version v2_0 - built 18:31:11, Aug  4 2005               
                                                                                
Platform: PC (I386)                                                             
Copyright (C) 2000, 2001, 2002, Red Hat, Inc.                                   
                                                                                
RAM: 0x00000000-0x000f0000, 0x00072ed0-0x000a0000 available                     
ver 00:0003  05-24-05                                                           
                                                                                
<press Ctrl+C to enter prompt mode>                                             
                                                                                
# Activate RDC-Keilven's RS232 Patch V2                                         
RedBoot>                                                                        
# Kernel size = 65504 bytes                                                     
# FW size = 2621444 bytes                                                       
                                                                                
# fwcheck: base = 0x00400000, size = 0x00000400                                 
# Firmware Checksum O.K                                                         
# Kernel copying......BEGIN                                                     
# Kernel copying......FINISH                                                    
                                                                                
mem_size: 1000000            

comment:9 Changed 6 years ago by florian

The kernel size looks wrong, it is way too small, I am not sure this is the file format expected by our WRT54GR, I will check against the vendor tarball.

comment:10 Changed 6 years ago by rwoodsmall

Same issue with current trunk (rev 32919). Have tried to shrink the kernel down a bit to no avail. Not sure where to go from here.

comment:11 Changed 5 years ago by jos.ferraris@…

Hi, i confirm the same issue with a Belkin F5D9230-4 v3000. the kamikaze work but with backfire and latest snapshot freeze just before decompress the kernel.
What can i do to trubleshoot or to help?
thanks

comment:12 Changed 5 years ago by anonymous

Are there some news for this issue ?

comment:13 Changed 5 years ago by mingice@…

1.make menuconfig,selct "RDC 321x",exit and save.
2.make kernel_menuconfig,in "kernel hacking" ,disable "magic_sysrq".exit.
3.make.
4.flash to ar525w.OK!

comment:14 Changed 5 years ago by anonymous

Would somebody be willing to upload a AA or BF working image to dropbox (or similar)? I'm having problems compiling from svn.

Thanks!

comment:15 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as accepted .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.