Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9769 closed defect (fixed)

DHCP doesn't work also just flashed ar71xx and may be 63xx

Reported by: desigabri Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

After have had a lot of troubles related to the DHCP I tryed some roll backs: I compiled new immages starting from the last v27699 and going behind with regular steps. So I tryed v27699, v27550, v27450, v27350 and v27200. The DHCP had serius probles if upgraded onto existing configurations (sysupgrade images) and never worked if flashed as upgrade-factory for the three newer versions and started working well for versions older then v27350 as for sysupgrade as for factory upgrades. So something changed after the v27350 trunk that made DHCP buggy. Verified on three WR841NDv7 (all 5 firmwares) and one WR1043ND (tested with 27200, 27350 and 27450). I suspect that the same issue is real for 63xx and may be for 47xx but I have to confirm it after having done similar tests.

Attachments (0)

Change History (8)

comment:1 follow-up: Changed 7 years ago by anonymous

What do you exactly mean by "DHCP doesn't work" and "lot of troubles"? Please describe the problem more detailedly, if you want somebody to pay attention.

Right now your explanation is so vague that nodoby understands the problem.

comment:2 follow-up: Changed 7 years ago by anonymous

Seems to be duplicate of #9753 opened by the same person.

comment:3 in reply to: ↑ 1 Changed 7 years ago by anonymous

Replying to anonymous:

What do you exactly mean by "DHCP doesn't work" and "lot of troubles"? Please describe the problem more detailedly, if you want somebody to pay attention.

Right now your explanation is so vague that nodoby understands the problem.

Right, I'm sorry if I wasn't anought clear in description.

I lived two stages of experiend troubles.
The first stage started after an imprecisated trunk: Clients loosed their IP and I had very mutch difficoult to get their IPs assigned again: tried renewing the IP from the client or restarting the DHCP service or the network or the LAN device from the AP (so for WLAN as for LAN).
I compiled newer trunks and the situation didn't changed. It seemed to became better but after a wile I had again the issue.
You have to know that in that steps I did only routers upgrades so the configurations of the routers where the same (upgraded trought sysupgrade firmware versions). I wrote the other ticket about these troubles but didn't signed as DEFECT, only wanted to ask attention about this (and nobody wrote or asked anymore informations).

The second stage of this experience is started when I decided to get more information for describing this issue to the developement people.
So I compiled some trunk versions going behind to try finding from when the trouble started.
So i compiled 27699, 27550, 27450, 27350 and 27200, just looking to try firmwares before and after some important modifications.
To try these new firmwares I didn't use my operative routers: I tryed initially with a spare one. I realizzed that new firmware versions flashed with factory firmware (the bigger one, which overwrites any comfiguration to basic settings), wheren't working because because I couldn't get the IP address to connect to the router after the flash. Also setting a fixed IP to the client and going to the administration page to take a look of the situazion didn't let me see anything wrong or different. I went behind from revision to revision until the 27350 and then also the 27200 and they started working well, so after the flash I could get the IP and start play whith configuration.
So I flashed with the older firmwares my operative routers (with factory firmware versions) and AFTER having loaded the saved configurations they started working well. I did the same for a WR1043ND with older and newers ones, loading the saved configuration and it started working well too (only three revisions, not all 5).
Because the troubles for factory upgrade and sysupgrade where all two related to the DHCP, I decided to write a new ticked as DEFETC. I'm pretty sure that I didn't get the evidence of the issue because initially I upgraded only the routers keeping the original configuration so the issue wasn't so bright. I had to start assignig fixed IPs and some time without assignig fixed IP I had the right IP to the clients but I couldn't see them connected... so I wrote: "a lot of troubles", I couldn't describe all because they appeared and desappeared during the last three trunk upgrades.
May be I was too mutch fast writing about a general defect for 47xx and 63xx. Yesterday night I tried the 27641 and 27653 onto a WRT54GS and it worked right at the first time. I haven't tested any 63xx in these two days but I thought they can have trouble too because the 27641 and 27653 gave me some DHCP troubles flashing a working router (I have troubles because the LAN clients get their IP from the WAN DHCP, but I associated this trouble to the possibility that it happens because the LAN DHCP doesn't work).
Finally I think I was wrong writing so fast about 47xx and 63xx related troubles. I apologize about them, I did so to avoid starting a new ticked again thinking that they are all related and that I could add news to the same thicket.
Anyway the DEFECT is very clear now. I don't know what causes it but I think it could be verified by you or other on WR841ND and WR1047ND and in general to any 71xx (May be)

comment:4 in reply to: ↑ 2 Changed 7 years ago by desigabri

Replying to anonymous:

Seems to be duplicate of #9753 opened by the same person.

yes it comes from the same situation but because I couldn't chenge the state fron task to DEFECT and because nobody answered or interested to them as task (I think task is something less importand then a defect like infomations or tips, May be I'm wrong), I decided to write a new ticket. I hope not to have done a tremendous mistake.

comment:5 Changed 7 years ago by desigabri

Ok I found the revision when the issue was introduct.

The trunk is 27375.
The file is uci.c

for 27374:
49 { .name = "reset" },
50 { .name = "enable_vlan" },

for 27375:
49 { .name = "reset", .val = "1" },
50 { .name = "enable_vlan", .val = "1" },

I applied this changes to the last trunk (v27730) and it works. This issue is related to the switch so not direclty to the DHCP service. Only gets the network stuck onto wr841ND and others 71xx (may be not all models) when you start from a fresh flash.
I'm not sure that it will resolve the others troubles I described, I need to test and I'll write about it.

comment:6 Changed 7 years ago by desigabri

hi developers and not, I'm happy to say that this issue is fixed
I just said that trying to apply the patch (the old uci.c file) the router became alive again. No people answered to this trade BUT I can confirm that the troubles came from the v27375 uci.c revision. I compiled new versions with old uci.c file and then I had my firmwares working. But looking to the modifications that developers made I had dubs about the true cause of the troubles. So after having compiled the last trunk SUCCESFULLY (with new uci.c version, not sure about the revision) and verified the right functionality of the routers, then I compiled the same trunk with the previus (incriminated) uci.c file (rev27375)...then I got my wr841ND_v5 stucked... :(((((((((
Anyway it confirmed that the problems are due to the uci.c file starting from v27375 trunk version. I think somone can close this ticket. Unfortunately none confirmed this issue BUT NOW IT IS ELIMINATED PLEASE CLOSE THIS TICKET...

comment:7 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.