Modify

Opened 7 years ago

Closed 7 years ago

#9761 closed defect (worksforme)

Extroot not working on NSLU2

Reported by: Costin Stroie <costinstroie@…> Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: base system Version: Backfire 10.03.1 RC5
Keywords: extroot Cc:

Description

I could not activate extroot on NSLU2, neither as overlay nor as whole_root. I have to mention extroot is working as overlay in RC4. I use an external HDD, with a Super Top bridge, usbid 14cd:6116, which uses the 'ums-cypress' module for usb storage, so it needs the 'kmod-usb-storage-extras' package, from the RC5 kernel (the RC4 kernel is missing the usbid specification, finally making smartmontools distroying the HDD data).
First, one question: only the 'block-mount' package is needed, isn't it? The other two, 'block-extroot' and 'block-hotplug', are not needed anymore, according to the extroot howto, am I right?
I started using the configuration from "After r26109" section and, when I could ssh, there was nothing mounted. Then, I have tried the instructions from "After r25787" section, using the overlay, and the result was the same. And in both cases, the fstab init script was enabled.
I noticed the drive is detected quite late, so I entered a 'sleep 20' line just before the end of the 'boot' init script, allowing the device to settle. Now the partitions got mounted accordingly, but as double mounts: there were both the mini_fo root and the sda2 mounted on '/' in one case and both the mtdblock5 and sda2 mounted on '/overlay' in the other case.
I had not the inspiration to save the logread output and I had to revert the device to RC4, since it is in production. But I have a syslog output on a remote machine (see below).
What to do? What am I doing wrong?

Jul 20 11:52:13 slugsy sysinit: udhcpc: setting default routers: 10.200.4.250 
Jul 20 11:52:13 slugsy sysinit: udhcpc: setting dns servers: 10.200.4.250 
Jul 20 11:52:13 slugsy kernel: PPP generic driver version 2.4.2 
Jul 20 11:52:13 slugsy sysinit: udhcpc: setting dns domain: ********** 
Jul 20 11:52:14 slugsy kernel: ip_tables: (C) 2000-2006 Netfilter Core Team 
Jul 20 11:52:14 slugsy ifup: Allowing Router Advertisements on lan (eth0) 
Jul 20 11:52:15 slugsy kernel: NET: Registered protocol family 24 
Jul 20 11:52:15 slugsy kernel: ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver 
Jul 20 11:52:15 slugsy kernel: PCI: enabling device 0000:00:01.2 (0140 -> 0142) 
Jul 20 11:52:15 slugsy kernel: ehci_hcd 0000:00:01.2: EHCI Host Controller 
Jul 20 11:52:15 slugsy kernel: ehci_hcd 0000:00:01.2: new USB bus registered, assigned bus number 1 
Jul 20 11:52:15 slugsy kernel: ehci_hcd 0000:00:01.2: Enabling legacy PCI PM 
Jul 20 11:52:15 slugsy kernel: ehci_hcd 0000:00:01.2: irq 26, io mem 0x48002000 
Jul 20 11:52:15 slugsy kernel: ehci_hcd 0000:00:01.2: USB 2.0 started, EHCI 1.00 
Jul 20 11:52:15 slugsy kernel: usb usb1: configuration #1 chosen from 1 choice 
Jul 20 11:52:15 slugsy kernel: hub 1-0:1.0: USB hub found 
Jul 20 11:52:15 slugsy kernel: hub 1-0:1.0: 5 ports detected 
Jul 20 11:52:16 slugsy kernel: Initializing USB Mass Storage driver... 
Jul 20 11:52:16 slugsy kernel: usbcore: registered new interface driver usb-storage 
Jul 20 11:52:16 slugsy kernel: USB Mass Storage support registered. 
Jul 20 11:52:16 slugsy kernel: usb 1-1: new high speed USB device using ehci_hcd and address 2 
Jul 20 11:52:16 slugsy kernel: usbcore: registered new interface driver ums-cypress 
Jul 20 11:52:16 slugsy kernel: usb 1-1: configuration #1 chosen from 1 choice 
Jul 20 11:52:16 slugsy kernel: hub 1-1:1.0: USB hub found 
Jul 20 11:52:17 slugsy kernel: nf_conntrack version 0.5.0 (469 buckets, 1876 max) 
Jul 20 11:52:17 slugsy kernel: CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use 
Jul 20 11:52:17 slugsy kernel: nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or 
Jul 20 11:52:17 slugsy kernel: sysctl net.netfilter.nf_conntrack_acct=1 to enable it. 
Jul 20 11:52:17 slugsy kernel: hub 1-1:1.0: 4 ports detected 
Jul 20 11:52:17 slugsy rdate: Synced with ptbtime2.ptb.de 
Jul 20 11:52:17 slugsy kernel: usb 1-1.4: new high speed USB device using ehci_hcd and address 3 
Jul 20 11:52:18 slugsy kernel: ath_hal: module license 'Proprietary' taints kernel. 
Jul 20 11:52:18 slugsy kernel: Disabling lock debugging due to kernel taint 
Jul 20 11:52:18 slugsy kernel: ath_hal: 2009-05-08 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, RF2425, REGOPS_FUNC, XR) 
Jul 20 11:52:18 slugsy kernel: usb 1-1.4: configuration #1 chosen from 1 choice 
Jul 20 11:52:19 slugsy kernel: scsi0 : SCSI emulation for USB Mass Storage devices 
Jul 20 11:52:19 slugsy kernel: ath_pci: trunk 
Jul 20 11:52:19 slugsy kernel: wlan: trunk 
Jul 20 11:52:19 slugsy kernel: wlan: mac acl policy registered 
Jul 20 11:52:19 slugsy kernel: ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (trunk) 
Jul 20 11:52:19 slugsy kernel: ath_rate_minstrel: look around rate set to 10% 
Jul 20 11:52:19 slugsy kernel: ath_rate_minstrel: EWMA rolloff level set to 75% 
Jul 20 11:52:19 slugsy kernel: ath_rate_minstrel: max segment size in the mrr set to 6000 us 
Jul 20 11:52:24 slugsy kernel: scsi 0:0:0:0: Direct-Access     WDC WD32 00BEVT-00ZCT0         PQ: 0 ANSI: 0 
Jul 20 11:52:24 slugsy kernel: sd 0:0:0:0: [sda] 625142448 512-byte logical blocks: (320 GB/298 GiB) 
Jul 20 11:52:24 slugsy kernel: sd 0:0:0:0: [sda] Write Protect is off 
Jul 20 11:52:24 slugsy kernel:  sda: sda1 sda2 sda3 
Jul 20 11:52:24 slugsy kernel: sd 0:0:0:0: [sda] Attached SCSI disk 
Jul 20 11:52:41 slugsy kernel: Adding 184736k swap on /dev/sda3.  Priority:-1 extents:1 across:184736k  
Jul 20 11:52:42 slugsy kernel: EXT4-fs (sda2): mounted filesystem with ordered data mode 
Jul 20 11:52:43 slugsy kernel: EXT4-fs (sda1): mounted filesystem with ordered data mode 
Jul 20 11:52:47 slugsy sysinit: Loading zones 
Jul 20 11:52:49 slugsy sysinit: Loading forwardings 
Jul 20 11:52:49 slugsy sysinit: Loading redirects 
Jul 20 11:52:49 slugsy sysinit: Loading rules 
Jul 20 11:52:49 slugsy sysinit: Loading includes 
Jul 20 11:52:49 slugsy sysinit: Optimizing conntrack 
Jul 20 11:52:49 slugsy sysinit: Loading interfaces 
Jul 20 11:52:49 slugsy firewall: adding lan (eth0) to zone lan 
Jul 20 11:52:51 slugsy sysinit: setting up led Status 

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by kiddyfurby

I can confirm the problem
If you install block-hotplug, sleep 20 won't be required

But still I have double /overlay mounted - the mtdblock and /dev/sda2 at the same time
there's also the mini_fo but I guess that doesn't matters?

comment:2 Changed 7 years ago by kiddyfurby

alright so the problem is, in rc5, the block-mount / hotplug packages are 0.1, not 0.2,
thus, unlike what the wiki at http://wiki.openwrt.org/doc/howto/extroot[[BR]]

we should follow the instruction for Before r25787 even rc5 is supposed to be r27608


basically that means is_rootfs = 1 is needed

my problem is solved

comment:3 Changed 7 years ago by phr3ak

We follow the 'Before r25787' section and doesn't work for us. Please check the problem. Thank You.

comment:4 Changed 7 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

I just tested it with RC5 and "option enabled 1", "option is_rootfs 1" and *no* "option target /overlay" works as intended. Whats left is a documentaiton issue.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.