Modify

Opened 7 years ago

Closed 6 years ago

#9758 closed defect (invalid)

FreeRadius2 mod-ippool build error

Reported by: tux Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: freeradius, ippool Cc:

Description

Hello, I need FreeRadius2 with mod_ippool on OpenWrt (ar71xx - Ubiquity RouterStation). I download OpenWrt from svn and change feeds/packages/net/freeradius2/Makefile. Compilation end with an error:

tux@tux:~/openwrt/$ svn co svn://svn.openwrt.org/openwrt/branches/backfire@27699
tux@tux:~/openwrt/backfire$ ./scripts/feeds update -a
tux@tux:~/openwrt/backfire$ ./scripts/feeds install -a
tux@tux:~/openwrt/backfire/feeds/packages/net/freeradius2/$ svn diff > freeradius2-ippool.patch
tux@tux:~/openwrt/backfire$ make menuconfig
tux@tux:~/openwrt/backfire$ ionice -c 3 nice -n 20 make -j 5 V=99
...

*** module rlm_eap_ikev2 is disabled.
configure: creating ./config.status
config.status: creating Makefile
=== configuring in src/modules/rlm_ippool (/home/tux/openwrt/backfire/build_dir/target-mips_r2_uClibc-0.9.30.1/freeradius-server-2.1.10/src/modules/rlm_ippool)
configure: running /bin/bash ./configure --disable-option-checking '--prefix=/usr'  '--target=mips-openwrt-linux' '--host=mips-openwrt-linux' '--build=i686-linux-gnu' '--program-prefix=' '--program-suffix=' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--libexecdir=/usr/lib' '--sysconfdir=/etc' '--datadir=/usr/share' '--localstatedir=/var' '--mandir=/usr/man' '--infodir=/usr/info' '--disable-nls' '--libdir=/usr/lib/freeradius2' '--libexecdir=/usr/lib/freeradius2' '--enable-shared' '--disable-static' '--disable-developer' '--with-threads' '--with-openssl-includes=/home/tux/openwrt/backfire/staging_dir/target-mips_r2_uClibc-0.9.30.1/usr/include' '--with-openssl-libraries=/home/tux/openwrt/backfire/staging_dir/target-mips_r2_uClibc-0.9.30.1/usr/lib' '--with-system-libtool' '--with-system-libltdl' '--enable-strict-dependencies' '--with-raddbdir=/etc/freeradius2' '--with-radacctdir=/var/db/radacct' '--with-logdir=/var/log' '--without-edir' '--without-snmp' '--without-rlm_checkval' '--without-rlm_dbm' '--without-rlm_counter' '--with-rlm_expr' '--with-rlm_eap' '--without-rlm_eap_sim' '--without-rlm_tux' '--with-rlm_ippool' '--without-rlm_krb5' '--without-rlm_otp' '--without-rlm_smsotp' '--without-rlm_pam' '--without-rlm_perl' '--without-rlm_python' '--without-rlm_smb' '--with-rlm_sql' '--with-rlm_sqlcounter' '--without-rlm_sqlhpwippool' '--without-rlm_sqlippool' '--without-rlm_sql_db2' '--without-rlm_sql_firebird' '--without-rlm_sql_freetds' '--without-rlm_sql_iodbc' '--without-rlm_sql_oracle' '--without-rlm_sql_sybase' '--without-rlm_sql_unixodbc' '--without-rlm_sql_log' '--without-rlm_unix' '--without-rlm_eap_tnc' '--without-rlm_eap_ikev2' '--without-rlm_opendirectory' '--without-rlm_wimax' '--without-rlm_ruby' '--without-rlm_ldap' '--without-rlm_sql_mysql' '--without-rlm_sql_postgresql' '--without-rlm_sql_sqlite' '--without-rlm_eap_peap' '--without-rlm_eap_tls' '--without-rlm_eap_ttls' '--without-rlm_attr-rewrite' '--without-rlm_radutmp' '--without-rlm_logintime' '--without-rlm_expiration' '--without-rlm_always' 'build_alias=i686-linux-gnu' 'host_alias=mips-openwrt-linux' 'target_alias=mips-openwrt-linux' 'CC=mips-openwrt-linux-uclibc-gcc' 'CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time -fhonour-copts -msoft-float ' 'LDFLAGS=-L/home/tux/openwrt/backfire/staging_dir/target-mips_r2_uClibc-0.9.30.1/usr/lib -L/home/tux/openwrt/backfire/staging_dir/target-mips_r2_uClibc-0.9.30.1/lib -L/home/tux/openwrt/backfire/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/usr/lib -L/home/tux/openwrt/backfire/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/lib ' 'LIBS=' 'CPPFLAGS=-I/home/tux/openwrt/backfire/staging_dir/target-mips_r2_uClibc-0.9.30.1/usr/include -I/home/tux/openwrt/backfire/staging_dir/target-mips_r2_uClibc-0.9.30.1/include -I/home/tux/openwrt/backfire/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/usr/include -I/home/tux/openwrt/backfire/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/include ' 'CXX=mips-openwrt-linux-uclibc-g++' 'CXXFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time -fhonour-copts -msoft-float ' --cache-file=/dev/null --srcdir=.
configure: loading site script /home/tux/openwrt/backfire/include/site/mips-openwrt-linux-uclibc
checking for mips-openwrt-linux-gcc... mips-openwrt-linux-uclibc-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... yes
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether mips-openwrt-linux-uclibc-gcc accepts -g... yes
checking for mips-openwrt-linux-uclibc-gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... mips-openwrt-linux-uclibc-gcc -E
checking for gdbm.h... no
checking for gdbm_open in -lgdbm... no
checking for gdbm_fdesc... no
configure: error: set --without-rlm_ippool to disable it explicitly.
configure: error: ./configure failed for src/modules/rlm_ippool
make[3]: *** [/home/tux/openwrt/backfire/build_dir/target-mips_r2_uClibc-0.9.30.1/freeradius-server-2.1.10/.configured_] Error 1
make[3]: Leaving directory `/home/tux/openwrt/backfire/feeds/packages/net/freeradius2'
make[2]: *** [package/feeds/packages/freeradius2/compile] Error 2
make[2]: Leaving directory `/home/tux/openwrt/backfire'
make[1]: *** [/home/tux/openwrt/backfire/staging_dir/target-mips_r2_uClibc-0.9.30.1/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/tux/openwrt/backfire'
make: *** [world] Error 2
tux@tux:~/openwrt/backfire$ 

Can you help me please?

Attachments (3)

freeradius2-ippool_change.patch (1.3 KB) - added by tux 7 years ago.
My changes in Freeradius2 Makefile
compilation-error.txt (5.2 KB) - added by anonymous 7 years ago.
ar71xx-routerstation_2.png (73.8 KB) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by tux

My changes in Freeradius2 Makefile

Changed 7 years ago by anonymous

Changed 7 years ago by anonymous

comment:1 Changed 6 years ago by nico

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.