Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9754 closed defect (obsolete)

3G connections and DNS problems - r27698

Reported by: Crazy Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi, I have a problem with r27698 and DNS using my 3G connection.

I tested 3 different ISP so the problem isn't my connection and different routers (MR3420 - DIR-320 - WR1043ND)

Here the log

Jul 19 19:33:00 OpenWrt kern.info kernel: Initializing USB Mass Storage driver...
Jul 19 19:33:00 OpenWrt kern.info kernel: usbcore: registered new interface driver usb-storage
Jul 19 19:33:00 OpenWrt kern.info kernel: USB Mass Storage support registered.
Jul 19 19:33:00 OpenWrt kern.info kernel: eth0: link down
Jul 19 19:33:01 OpenWrt kern.info kernel: device eth0 entered promiscuous mode
Jul 19 19:33:01 OpenWrt user.notice ifup: Enabling Router Solicitations on loopback (lo)
Jul 19 19:33:01 OpenWrt user.notice rdate: No usable time server for loopback found
Jul 19 19:33:02 OpenWrt user.notice ifup: Enabling Router Solicitations on lan (br-lan)
Jul 19 19:33:03 OpenWrt user.notice rdate: No usable time server for lan found
Jul 19 19:33:31 OpenWrt kern.info kernel: PPP generic driver version 2.4.2
Jul 19 19:33:31 OpenWrt kern.warn kernel: ppp_async: Unknown symbol crc_ccitt_table (err 0)
Jul 19 19:33:32 OpenWrt daemon.err pppd[715]: unrecognized option '/dev/ttyUSB0'
Jul 19 19:33:32 OpenWrt kern.info kernel: Compat-wireless backport release: compat-wireless-2011-06-23
Jul 19 19:33:32 OpenWrt kern.info kernel: Backport based on wireless-testing.git master-2011-06-22
Jul 19 19:33:32 OpenWrt kern.info kernel: cfg80211: Calling CRDA to update world regulatory domain
Jul 19 19:33:33 OpenWrt kern.info kernel: cfg80211: World regulatory domain updated:
Jul 19 19:33:33 OpenWrt kern.info kernel: cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Jul 19 19:33:33 OpenWrt kern.info kernel: cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jul 19 19:33:33 OpenWrt kern.info kernel: cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Jul 19 19:33:33 OpenWrt kern.info kernel: cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Jul 19 19:33:33 OpenWrt kern.info kernel: cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jul 19 19:33:33 OpenWrt kern.info kernel: cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jul 19 19:33:34 OpenWrt kern.debug kernel: PCI: Setting latency timer of device 0000:00:00.0 to 64
Jul 19 19:33:34 OpenWrt kern.debug kernel: ath: EEPROM regdomain: 0x0
Jul 19 19:33:34 OpenWrt kern.debug kernel: ath: EEPROM indicates default country code should be used
Jul 19 19:33:34 OpenWrt kern.debug kernel: ath: doing EEPROM country->regdmn map search
Jul 19 19:33:34 OpenWrt kern.debug kernel: ath: country maps to regdmn code: 0x3a
Jul 19 19:33:34 OpenWrt kern.debug kernel: ath: Country alpha2 being used: US
Jul 19 19:33:34 OpenWrt kern.debug kernel: ath: Regpair used: 0x3a
Jul 19 19:33:34 OpenWrt kern.debug kernel: ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Jul 19 19:33:34 OpenWrt kern.debug kernel: Registered led device: ath9k-phy0
Jul 19 19:33:34 OpenWrt kern.info kernel: ieee80211 phy0: Atheros AR9287 Rev:2 mem=0xb0000000, irq=72
Jul 19 19:33:34 OpenWrt kern.info kernel: cfg80211: Calling CRDA for country: US
Jul 19 19:33:34 OpenWrt kern.info kernel: ip_tables: (C) 2000-2006 Netfilter Core Team
Jul 19 19:33:35 OpenWrt kern.info kernel: cfg80211: Regulatory domain changed to country: US
Jul 19 19:33:35 OpenWrt kern.info kernel: cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Jul 19 19:33:35 OpenWrt kern.info kernel: cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
Jul 19 19:33:35 OpenWrt kern.info kernel: cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
Jul 19 19:33:35 OpenWrt kern.info kernel: cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jul 19 19:33:35 OpenWrt kern.info kernel: cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jul 19 19:33:35 OpenWrt kern.info kernel: cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jul 19 19:33:35 OpenWrt kern.info kernel: cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
Jul 19 19:33:35 OpenWrt kern.info kernel: NET: Registered protocol family 24
Jul 19 19:33:35 OpenWrt kern.info kernel: nf_conntrack version 0.5.0 (462 buckets, 1848 max)
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver usbserial
Jul 19 19:33:36 OpenWrt kern.info kernel: USB Serial support registered for generic
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver usbserial_generic
Jul 19 19:33:36 OpenWrt kern.info kernel: usbserial: USB Serial Driver core
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-alauda
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-cypress
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-datafab
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-freecom
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-isd200
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-jumpshot
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-karma
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-sddr09
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-sddr55
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver ums-usbat
Jul 19 19:33:36 OpenWrt kern.info kernel: USB Serial support registered for GSM modem (1-port)
Jul 19 19:33:36 OpenWrt kern.info kernel: usbcore: registered new interface driver option
Jul 19 19:33:36 OpenWrt kern.info kernel: option: v0.7.2:USB Driver for GSM modems
Jul 19 19:33:36 OpenWrt user.notice usb-modeswitch: 1-0:1.0: Manufacturer=Linux_2.6.39.2_ehci_hcd Product=Atheros_AR91xx_built-in_EHCI_controller Serial=ar71xx-ehci
Jul 19 19:33:38 OpenWrt kern.info kernel: device wlan0 entered promiscuous mode
Jul 19 19:33:38 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jul 19 19:33:38 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jul 19 19:33:42 OpenWrt daemon.info hostapd: wlan0: STA d8:5d:4c:92:c6:7b IEEE 802.11: authenticated
Jul 19 19:33:42 OpenWrt daemon.info hostapd: wlan0: STA d8:5d:4c:92:c6:7b IEEE 802.11: associated (aid 1)
Jul 19 19:33:42 OpenWrt daemon.info hostapd: wlan0: STA d8:5d:4c:92:c6:7b WPA: pairwise key handshake completed (RSN)
Jul 19 19:33:42 OpenWrt kern.info kernel: device wlan0 left promiscuous mode
Jul 19 19:33:42 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jul 19 19:33:42 OpenWrt kern.info kernel: device wlan0 entered promiscuous mode
Jul 19 19:33:42 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jul 19 19:33:42 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jul 19 19:33:43 OpenWrt user.info sysinit: Loading defaults
Jul 19 19:33:43 OpenWrt user.info sysinit: Loading synflood protection
Jul 19 19:33:43 OpenWrt user.info sysinit: Adding custom chains
Jul 19 19:33:44 OpenWrt user.info sysinit: Loading zones
Jul 19 19:33:45 OpenWrt user.info sysinit: Loading forwardings
Jul 19 19:33:45 OpenWrt user.info sysinit: Loading redirects
Jul 19 19:33:45 OpenWrt user.info sysinit: Loading rules
Jul 19 19:33:45 OpenWrt user.info sysinit: Loading includes
Jul 19 19:33:45 OpenWrt user.info sysinit: Optimizing conntrack
Jul 19 19:33:45 OpenWrt user.info sysinit: Loading interfaces
Jul 19 19:33:45 OpenWrt user.info firewall: adding lan (br-lan) to zone lan
Jul 19 19:33:45 OpenWrt user.info sysinit: /sbin/uci: Entry not found
Jul 19 19:33:45 OpenWrt user.info sysinit: /sbin/uci: Entry not found
Jul 19 19:33:46 OpenWrt authpriv.info dropbear[1331]: Running in background
Jul 19 19:33:46 OpenWrt user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Jul 19 19:33:46 OpenWrt user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Jul 19 19:33:50 OpenWrt daemon.info dnsmasq[1373]: started, version 2.57 cachesize 150
Jul 19 19:33:50 OpenWrt daemon.info dnsmasq[1373]: compile time options: IPv6 GNU-getopt no-DBus no-I18N DHCP TFTP no-IDN
Jul 19 19:33:50 OpenWrt daemon.info dnsmasq-dhcp[1373]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Jul 19 19:33:50 OpenWrt daemon.info dnsmasq[1373]: using local addresses only for domain lan
Jul 19 19:33:50 OpenWrt daemon.info dnsmasq[1373]: reading /tmp/resolv.conf.auto
Jul 19 19:33:50 OpenWrt daemon.info dnsmasq[1373]: using nameserver 1.1.1.1#53
Jul 19 19:33:50 OpenWrt daemon.info dnsmasq[1373]: using local addresses only for domain lan
Jul 19 19:33:50 OpenWrt daemon.info dnsmasq[1373]: read /etc/hosts - 1 addresses
Jul 19 19:33:50 OpenWrt daemon.info dnsmasq-dhcp[1373]: read /etc/ethers - 0 addresses
Jul 19 19:33:50 OpenWrt user.info sysinit: setting up led USB
Jul 19 19:33:50 OpenWrt kern.debug kernel: ar71xx-wdt: enabling watchdog timer
Jul 19 19:34:45 OpenWrt kern.info kernel: usb 1-1: new high speed USB device number 2 using ar71xx-ehci
Jul 19 19:34:45 OpenWrt kern.info kernel: option 1-1:1.0: GSM modem (1-port) converter detected
Jul 19 19:34:45 OpenWrt kern.info kernel: usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
Jul 19 19:34:45 OpenWrt kern.info kernel: option 1-1:1.1: GSM modem (1-port) converter detected
Jul 19 19:34:45 OpenWrt kern.info kernel: usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
Jul 19 19:34:45 OpenWrt kern.info kernel: option 1-1:1.2: GSM modem (1-port) converter detected
Jul 19 19:34:45 OpenWrt kern.info kernel: usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
Jul 19 19:34:45 OpenWrt user.notice usb-modeswitch: 1-1:1.0: Manufacturer=Huawei_Technologies Product=HUAWEI_Mobile Serial=?
Jul 19 19:34:45 OpenWrt user.notice usb-modeswitch: 1-1:1.0: Selecting /etc/usb_modeswitch.d/12d1:1001 for mode switching
Jul 19 19:34:45 OpenWrt user.notice 3g-hotplug: Starting interface wan for device ttyUSB0
Jul 19 19:34:45 OpenWrt user.notice usb-modeswitch: 1-1:1.1: Manufacturer=Huawei_Technologies Product=HUAWEI_Mobile Serial=?
Jul 19 19:34:45 OpenWrt user.notice usb-modeswitch: 1-1:1.1: Selecting /etc/usb_modeswitch.d/12d1:1001 for mode switching
Jul 19 19:34:46 OpenWrt user.notice usb-modeswitch: 1-1:1.2: Manufacturer=Huawei_Technologies Product=HUAWEI_Mobile Serial=?
Jul 19 19:34:46 OpenWrt user.notice usb-modeswitch: 1-1:1.2: Selecting /etc/usb_modeswitch.d/12d1:1001 for mode switching
Jul 19 19:34:49 OpenWrt daemon.info dnsmasq[1373]: reading /tmp/resolv.conf.auto
Jul 19 19:34:49 OpenWrt daemon.info dnsmasq[1373]: using nameserver 1.1.1.1#53
Jul 19 19:34:49 OpenWrt daemon.info dnsmasq[1373]: using local addresses only for domain lan
Jul 19 19:34:49 OpenWrt daemon.notice pppd[1515]: pppd 2.4.4 started by root, uid 0
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: abort on (BUSY)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: abort on (NO CARRIER)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: abort on (ERROR)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: report (CONNECT)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: timeout set to 10 seconds
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: send (AT&F^M)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: expect (OK)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: AT&F^M^M
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: OK
Jul 19 19:34:50 OpenWrt local2.info chat[1520]:  -- got it
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: send (ATE1^M)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: expect (OK)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: ^M
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: ATE1^M^M
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: OK
Jul 19 19:34:50 OpenWrt local2.info chat[1520]:  -- got it
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: send (AT+CGDCONT=1,"IP","datacard.tre.it"^M)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: timeout set to 30 seconds
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: expect (OK)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: ^M
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: AT+CGDCONT=1,"IP","datacard.tre.it"^M^M
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: OK
Jul 19 19:34:50 OpenWrt local2.info chat[1520]:  -- got it
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: send (ATD*99***1#^M)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: expect (CONNECT)
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: ^M
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: ATD*99***1#^M^M
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: CONNECT
Jul 19 19:34:50 OpenWrt local2.info chat[1520]:  -- got it
Jul 19 19:34:50 OpenWrt local2.info chat[1520]: send ( ^M)
Jul 19 19:34:50 OpenWrt daemon.info pppd[1515]: Serial connection established.
Jul 19 19:34:50 OpenWrt daemon.info pppd[1515]: Using interface 3g-wan
Jul 19 19:34:50 OpenWrt daemon.notice pppd[1515]: Connect: 3g-wan <--> /dev/ttyUSB0
Jul 19 19:34:54 OpenWrt daemon.warn pppd[1515]: Could not determine remote IP address: defaulting to 10.64.64.64
Jul 19 19:34:54 OpenWrt daemon.notice pppd[1515]: local  IP address 10.93.4.116
Jul 19 19:34:54 OpenWrt daemon.notice pppd[1515]: remote IP address 10.64.64.64
Jul 19 19:34:55 OpenWrt user.notice ifup: Enabling Router Solicitations on wan (3g-wan)
Jul 19 19:34:55 OpenWrt user.info firewall: adding wan (3g-wan) to zone wan
Jul 19 19:35:05 OpenWrt user.notice rdate: Failed to sync with time-b.nist.gov
Jul 19 19:35:15 OpenWrt user.notice rdate: Failed to sync with time-a.nist.gov
Jul 19 19:35:25 OpenWrt user.notice rdate: Failed to sync with ptbtime1.ptb.de
Jul 19 19:35:35 OpenWrt user.notice rdate: Failed to sync with ntp.xs4all.nl
Jul 19 19:35:45 OpenWrt user.notice rdate: Failed to sync with ptbtime2.ptb.de

Please help me :(
Many thanks

Attachments (1)

40-rdate.patch (458 bytes) - added by Luka 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by Luka

Hi,

I think this is happening because the hotplug script iface/40-rdate is executed before the dns change is picked up by dnsmasq. To solve this you can either:

a) use IP addresses instead of host names in config/timeserver or

b) introduce a little delay in 40-rdate script before rdate is executed - the 40-rdate.patch (attached) makes the script first try for 10s to resolve the timeserver and only then sync time. This solved the (I guess, the same) problem for me...

Changed 7 years ago by Luka

comment:2 Changed 7 years ago by Crazy

Thanks Luka, please can you tell me how I can add this patch ?

Many thanks

comment:3 Changed 6 years ago by nbd

  • Resolution set to obsolete
  • Status changed from new to closed

obsoleted by the use of ntpd

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.