Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9742 closed defect (fixed)

Error compiling uhttpd from trunk r27687

Reported by: massy Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

make[4]: Entering directory `/home/massy/Scrivania/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.32/uhttpd'
mips-openwrt-linux-uclibc-gcc -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -msoft-float -I/home/massy/Scrivania/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.32/usr/include -I/home/massy/Scrivania/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.32/include -I/home/massy/Scrivania/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-linaro_uClibc-0.9.32/usr/include -I/home/massy/Scrivania/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-linaro_uClibc-0.9.32/include -Wall --std=gnu99 -DHAVE_SHADOW -DHAVE_CGI -DHAVE_LUA -DHAVE_TLS -c -o uhttpd.o uhttpd.c
In file included from uhttpd.c:21:0:
uhttpd.h:45:25: fatal error: openssl/ssl.h: No such file or directory
compilation terminated.
make[4]: * [uhttpd.o] Error 1

Attachments (0)

Change History (7)

comment:1 Changed 7 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed
make defconfig

comment:2 Changed 7 years ago by Pilot6 <hanipouspilot@…>

  • Resolution worksforme deleted
  • Status changed from closed to reopened

It does not work if openssl is not already installed.
make defconfig does not show any errors, but uhttpd does not compile, because of absense of openssl.

comment:3 Changed 7 years ago by Pilot6 <hanipouspilot@…>

The problem is that TLS provider is not set by default in menuconfig. I had manually to set it. Please fix Makefile.

comment:4 Changed 7 years ago by Pilot6 <hanipouspilot@…>

The fact is that even when lua or tls are not selected build system tries to find both TLS packages and stops with an error if both are not there.

comment:5 Changed 7 years ago by Pilot6 <hanipouspilot@…>

Now built successfully but I have installed both openssl and cyassl. TLS support is ubchecked in menuconfig.

uhhtpd is being compiled only when I compile both TLS packages, and both are installed into target. Thats not too good.

comment:6 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r27689.

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.