Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9729 closed defect (worksforme)

siproxd - defective depend on libltd

Reported by: ew-tech@… Owned by: developers
Priority: response-needed Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03.1 RC5
Keywords: libltd depend Cc:

Description

backfire rc5

The siproxd for voip is unstartable

root@charybdis:/etc/config# /etc/init.d/siproxd start
/usr/sbin/siproxd: can't load library 'libltdl.so.3'

libltd 2.4.1 is installed from rc1

A newer libltd did not exist in rc5 packages

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by jow

  • Priority changed from normal to response-needed

On which platform? I can not reproduce it here.

jow@wws-7 $ ssh root@10.11.12.151 -p 22
Warning: Permanently added '10.11.12.151' (RSA) to the list of known hosts.
root@10.11.12.151's password: 
  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 Backfire (10.03.1-RC5, r27608) --------------------------
  * 1/3 shot Kahlua    In a shot glass, layer Kahlua 
  * 1/3 shot Bailey's  on the bottom, then Bailey's, 
  * 1/3 shot Vodka     then Vodka.
 ---------------------------------------------------
root@OpenWrt:~# opkg install siproxd   
Installing siproxd (0.7.1-3) to root...
Downloading http://downloads.openwrt.org/backfire/10.03.1-rc5/ar71xx/packages/siproxd_0.7.1-3_ar71xx.ipk.
Configuring siproxd.
root@OpenWrt:~# siproxd -v
siproxd: invalid option -- v
04:46:38 INFO:siproxd.c:229 siproxd-0.7.1-4804 mips-openwrt-linux-gnu starting up
04:46:38 ERROR:readconf.c:99 could not open config file: No such file or directory
root@OpenWrt:~# 

comment:2 Changed 7 years ago by ew-tech@…

This is the TP-LINK TL-WR1043ND ar71xx rc5 base

root@charybdis:/usr/lib# /etc/init.d/siproxd start
/usr/sbin/siproxd: can't load library 'libltdl.so.3'

Installed from rc1 is version 2.4.1, but no newer is available

root@charybdis:/usr/lib# opkg install libltdl
Package libltdl (2.4-1) installed in root is up to date.

comment:3 Changed 7 years ago by jow

Make sure your opkg.conf points to rc5.

comment:4 Changed 7 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

Well since you shown in #6014 that siproxd starts for you on rc5 I'm not sure what this ticket is even about - I cannot reproduce the problem.

comment:5 Changed 7 years ago by ew-tech@…

I have placed a link /usr/lib/libltdl.so.3 to the existing libltdl.7.1. That was the missing part.

comment:6 Changed 7 years ago by jow

root@OpenWrt:/# cd /tmp/
root@OpenWrt:/tmp# wget http://downloads.openwrt.org/backfire/10.03.1-rc5/ar71xx
/packages/siproxd_0.7.1-3_ar71xx.ipk
Connecting to downloads.openwrt.org (78.24.191.177:80)
siproxd_0.7.1-3_ar71 100% |*******************************| 53042  --:--:-- ETA
root@OpenWrt:/tmp# tar -xzf siproxd_0.7.1-3_ar71xx.ipk 
root@OpenWrt:/tmp# tar -xzf data.tar.gz 
root@OpenWrt:/tmp# ldd usr/sbin/siproxd 
        libltdl.so.7 => not found
        libresolv.so.0 => /lib/libresolv.so.0 (0x2aabe000)
        libosipparser2.so.3 => not found
        libosip2.so.3 => not found
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2aacf000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x2aaef000)
        libc.so.0 => /lib/libc.so.0 (0x2ab13000)
        ld-uClibc.so.0 => /lib/ld-uClibc.so.0 (0x2aaa8000)

Definitely not linking against libltdl.so.3, no idea where you got your package from.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.