Modify

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#9726 closed defect (fixed)

any LuCI 0.10 VLAN changes removes option 'reset' '1' and option 'enable_vlan' '1' from the switch config in /etc/config/network

Reported by: Tim Miller Dyck <tim@…> Owned by: jow
Priority: response-needed Milestone: Backfire 10.03.1
Component: luci Version: Backfire 10.03.1 RC5
Keywords: switch vlan reset enable_vlan Cc:

Description

On a fresh install of Backfire 10.03.1-RC5 on a TP-LINK TL-WR1043ND, making any VLAN changes in LuCI 0.10 causes the reset and enable_vlan settings to be lost from /etc/config/network. This causes VLAN problems after a reboot.

Steps to reproduce:

mtd -r erase rootfs_data

Switch config in /etc/config/network is:

...
config 'switch'
        option 'name' 'rtl8366rb'
        option 'reset' '1'
        option 'enable_vlan' '1'
...

Using LuCI, make any VLAN change, e.g. set Port 3 in VLAN1 to off and then Save & Apply

In /etc/config/network, the VLAN1 config section is properly updated to omit the designated port, but the overall switch config is now:

...
config 'switch'
        option 'name' 'rtl8366rb'
...

(I picked Trunk in the version drop-down but that is because RC5 is not listed there yet -- the testing above is with RC5.)

Thanks,
Tim Miller Dyck

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by jow

  • Owner set to jow
  • Priority changed from normal to response-needed
  • Status changed from new to accepted
  • Version changed from Trunk to Backfire 10.03.1 RC5

Hi, thank yor for reporting this, I pushed a change to LuCI to solve this: http://luci.subsignal.org/trac/changeset/7294 - can you test this?

You can patch it on the router by issuing the command below.

wget -qO/usr/lib/lua/luci/model/cbi/admin_network/vlan.lua http://luci.subsignal.org/trac/export/7294/luci/branches/luci-0.10/modules/admin-full/luasrc/model/cbi/admin_network/vlan.lua

comment:2 Changed 7 years ago by Tim Miller Dyck <tim@…>

Tested and confirmed fixed. Thanks!

-Tim Miller Dyck

comment:3 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

Thanks for the feedback.

comment:4 Changed 6 years ago by Tim Miller Dyck <tim@…>

Note to others: The manual fix above is not needed for -RC6. It is included already.

-Tim Miller Dyck

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.