Modify

Opened 7 years ago

Closed 6 years ago

#9713 closed defect (fixed)

FFMpeg seg fault

Reported by: luvar@… Owned by: developers
Priority: low Milestone: Bugs Paradise
Component: packages Version: Trunk
Keywords: ffmpeg, uvc, webcam Cc: luvar@…

Description

After installing bleeding edge, r27340 on TP-MR3220 I have tried to record some video from connected usb camera. First problem is that ffmpeg needs libpostproc library, but it is not in its dependencies. Second bug is problem with seg fault which can be causued also by bad parameters.

opkg update
opkg -d ram install ffmpeg libpostproc
LD_LIBRARY_PATH=/tmp/usr/lib/ /tmp/usr/bin/ffmpeg -f video4linux2 -vframes 1 -s 320x240 -r 1 -i /dev/video0 -f ffm /tmp/out.ffm

PS: I have tried to stream video through mjpg-streamer which failed with no error. Ill try to debug it more and Ill create probably ticket for it too.
Output:

FFmpeg version SVN-r12898, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --enable-cross-compile --cross-prefix=mips-openwrt-linux-uclibc- --arch=mips --prefix=/usr --enable-shared --enable-static --disable-debug --enable-ffmpeg --enable-ffserver --enable-gpl --enable-libfaad --disable-mmx --disable-mmx2 --enable-pthreads --disable-optimizations --enable-small --disable-stripping --disable-vhook --enable-zlib --enable-postproc --disable-encoders --disable-decoders --enable-decoder=ac3 --enable-decoder=atrac3 --enable-decoder=h264 --enable-decoder=jpegls --enable-decoder=mp3 --enable-decoder=mpeg1video --enable-decoder=mpeg2video --enable-decoder=mpeg4 --enable-decoder=mpeg4aac --enable-decoder=mpegvideo --enable-decoder=png --enable-decoder=wmav1 --enable-decoder=wmav2 --enable-decoder=zlib --disable-muxers --enable-muxer=ffm --disable-demuxers --enable-demuxer=ac3 --enable-demuxer=h264 --enable-demuxer=mp3 --enable-demuxer=mpegts --enable-demuxer=mpegvideo --enable-demuxer=rtsp --enable-demuxer=sdp --disable-parsers --enable-parser=ac3 --enable-parser=h264 --enable-parser=mpegaudio --enable-parser=mpegvideo --disable-bsfs --disable-protocols --enable-protocol=rtp --enable-protocol=udp
  libavutil version: 49.6.0
  libavcodec version: 51.55.0
  libavformat version: 52.13.0
  libavdevice version: 52.0.0
  built on Mar 19 2010 23:13:11, gcc: 4.3.3
[video4linux2 @ 0x2b1ec350][3]Capabilities: 4000001
Input #0, video4linux2, from '/dev/video0':
  Duration: N/A, start: 5916.623115, bitrate: 1228 kb/s
    Stream #0.0: Video: YUY2 / 0x32595559, yuyv422, 320x240, 1228 kb/s,  1.00 tb(r)
Could not open '/tmp/out.ffm'
Segmentation fault



root@OpenWrt:~# df -h /tmp/
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    14.4M      4.0M     10.4M  28% /tmp

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by florian

Please retry with r28063

comment:2 Changed 6 years ago by colchaodemola@…

I have tried with r28063 to capture from mu foscam IP Camera.
It needs filters to proccess the input , so i had to remove the --disable-filters from Makefile.
And it seg fault.

comment:3 Changed 6 years ago by nico

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed in [28467], try using libffmeg-full

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.