Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9688 closed defect (fixed)

hasciicam fails to compile on trunk

Reported by: oss@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

[wrtbuild@builder trunk]$ make -j V=99 package/hasciicam/compile
make[1]: Entering directory `/home/wrtbuild/trunk'
make[2]: Entering directory `/home/wrtbuild/trunk/package/libtool'
make[2]: Entering directory `/home/wrtbuild/trunk/package/ncurses'
make[2]: Entering directory `/home/wrtbuild/trunk/feeds/packages/libs/gettext'
make[2]: Entering directory `/home/wrtbuild/trunk/feeds/packages/libs/libiconv'
make[2]: Leaving directory `/home/wrtbuild/trunk/package/libtool'
make[2]: Leaving directory `/home/wrtbuild/trunk/feeds/packages/libs/libiconv'
make[2]: Leaving directory `/home/wrtbuild/trunk/feeds/packages/libs/gettext'
make[2]: Leaving directory `/home/wrtbuild/trunk/package/ncurses'
make[2]: Entering directory `/home/wrtbuild/trunk/package/ncurses'
make[2]: Leaving directory `/home/wrtbuild/trunk/package/ncurses'
make[2]: Entering directory `/home/wrtbuild/trunk/feeds/packages/libs/aalib'
make[2]: Leaving directory `/home/wrtbuild/trunk/feeds/packages/libs/aalib'
make[2]: Entering directory `/home/wrtbuild/trunk/feeds/packages/multimedia/hasciicam'
CFLAGS="-Os -pipe -march=24kc -funit-at-a-time -fhonour-copts -msoft-float  -I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/include " CXXFLAGS="-Os -pipe -march=24kc -funit-at-a-time -fhonour-copts -msoft-float  -I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/include " LDFLAGS="-L/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/usr/lib -L/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/lib -L/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/usr/lib -L/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/lib " make -j1 -C /home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/hasciicam-20080922/. AR=mips-openwrt-linux-uclibc-ar AS="mips-openwrt-linux-uclibc-gcc -c -Os -pipe -march=24kc -funit-at-a-time -fhonour-copts -msoft-float" LD=mips-openwrt-linux-uclibc-ld NM=mips-openwrt-linux-uclibc-nm CC="mips-openwrt-linux-uclibc-gcc" GCC="mips-openwrt-linux-uclibc-gcc" CXX="mips-openwrt-linux-uclibc-g++" RANLIB=mips-openwrt-linux-uclibc-ranlib STRIP=mips-openwrt-linux-uclibc-strip OBJCOPY=mips-openwrt-linux-uclibc-objcopy OBJDUMP=mips-openwrt-linux-uclibc-objdump SIZE=mips-openwrt-linux-uclibc-size CROSS="mips-openwrt-linux-uclibc-" ARCH="mips" ;
make[3]: Entering directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/hasciicam-20080922'
make  all-am
make[4]: Entering directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/hasciicam-20080922'
if mips-openwrt-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I. -I.   -I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/include   -Os -pipe -march=24kc -funit-at-a-time -fhonour-copts -msoft-float  -O3 -pipe -ffast-math -MT hasciicam.o -MD -MP -MF ".deps/hasciicam.Tpo" -c -o hasciicam.o hasciicam.c; \
        then mv -f ".deps/hasciicam.Tpo" ".deps/hasciicam.Po"; else rm -f ".deps/hasciicam.Tpo"; exit 1; fi
hasciicam.c:42:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[4]: *** [hasciicam.o] Error 1
make[4]: Leaving directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/hasciicam-20080922'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/hasciicam-20080922'
make[2]: *** [/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/hasciicam-20080922/.built] Error 2
make[2]: Leaving directory `/home/wrtbuild/trunk/feeds/packages/multimedia/hasciicam'
make[1]: *** [package/feeds/packages/hasciicam/compile] Error 2
make[1]: Leaving directory `/home/wrtbuild/trunk'
make: *** [package/hasciicam/compile] Error 2

I've verified that all the video kernel modules are enabled as modules. This is on SVN Revision: 27574 for the ar71xx build of WNDR3700.

Attachments (0)

Change History (7)

comment:1 Changed 7 years ago by mazilo

hasciicam is looking for staging_dir/<toolchain platform>/include/linux/videodev.h file. Make sure your system has that file. On mine with multiple environments, the videodev.h file is found in every staging_dir/<toolchain platform>/include/linux directory as shown below:

[mazilo@Mi:/opt/openwrt-svn-trunk 45%] ~ find staging_dir/ -name videodev.h -print
staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/include/linux/videodev.h
staging_dir/toolchain-arm_v5te_gcc-linaro_uClibc-0.9.32_eabi/include/linux/videodev.h

comment:2 Changed 7 years ago by oss@…

I disabled "hasciicam" to continue the compile and it died here as well:

[wrtbuild@builder trunk]$ make V=99 package/libv4l/compile
make[1]: Entering directory `/home/wrtbuild/trunk'
make[2]: Entering directory `/home/wrtbuild/trunk/feeds/packages/libs/libv4l'
make -C /home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1 DESTDIR="/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1/ipkg-install" PREFIX="/usr" AR=mips-openwrt-linux-uclibc-ar AS="mips-openwrt-linux-uclibc-gcc -c -Os -pipe -march=24kc -funit-at-a-time -fhonour-copts -msoft-float -fpic" LD=mips-openwrt-linux-uclibc-ld NM=mips-openwrt-linux-uclibc-nm CC="mips-openwrt-linux-uclibc-gcc" GCC="mips-openwrt-linux-uclibc-gcc" CXX="mips-openwrt-linux-uclibc-g++" RANLIB=mips-openwrt-linux-uclibc-ranlib STRIP=mips-openwrt-linux-uclibc-strip OBJCOPY=mips-openwrt-linux-uclibc-objcopy OBJDUMP=mips-openwrt-linux-uclibc-objdump SIZE=mips-openwrt-linux-uclibc-size CFLAGS="-Os -pipe -march=24kc -funit-at-a-time -fhonour-copts -msoft-float -fpic " CXXFLAGS="-Os -pipe -march=24kc -funit-at-a-time -fhonour-copts -msoft-float -fpic " CPPFLAGS="-I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/include " LDFLAGS="-L/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/usr/lib -L/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/lib -L/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/usr/lib -L/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/lib "  all install
make[3]: Entering directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1'
make -C libv4lconvert V4L2_LIB_VERSION=0.6.1 all
make[4]: Entering directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1/libv4lconvert'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1/libv4lconvert'
make -C libv4l2 V4L2_LIB_VERSION=0.6.1 all
make[4]: Entering directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1/libv4l2'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1/libv4l2'
make -C libv4l1 V4L2_LIB_VERSION=0.6.1 all
make[4]: Entering directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1/libv4l1'
mips-openwrt-linux-uclibc-gcc -Wp,-MMD,"libv4l1.d",-MQ,"libv4l1.o",-MP -c -I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/target-mips_uClibc-0.9.32/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/usr/include -I/home/wrtbuild/trunk/staging_dir/toolchain-mips_gcc-linaro_uClibc-0.9.32/include  -I../include -I../../../include -fvisibility=hidden -fPIC -Os -pipe -march=24kc -funit-at-a-time -fhonour-copts -msoft-float -fpic  -o libv4l1.o libv4l1.c
libv4l1.c:53:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[4]: *** [libv4l1.o] Error 1
make[4]: Leaving directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1/libv4l1'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1'
make[2]: *** [/home/wrtbuild/trunk/build_dir/target-mips_uClibc-0.9.32/libv4l-0.6.1/.built] Error 2
make[2]: Leaving directory `/home/wrtbuild/trunk/feeds/packages/libs/libv4l'
make[1]: *** [package/feeds/packages/libv4l/compile] Error 2
make[1]: Leaving directory `/home/wrtbuild/trunk'
make: *** [package/libv4l/compile] Error 2

Obviously this file is missing from that directory, that is what this bug is about. Why is that file missing from the ar71xx build? Have you done a recent ar71xx build?

comment:3 Changed 7 years ago by anonymous

I just did the following to build AR71XX generic firmware from scratch as follows:

1. 'svn up' to r27575.
2. make distclean
3. make

The compilation defaulted to linux-2.6.39.2 which ONLY has linux/videodev2.h (not linux/videodev.h) file. This will definitely break the compilation because hasciicam package requires linux/videodev.h file. However, it had no problem to successfully compile libv4l package.

comment:4 Changed 7 years ago by anonymous

I'll do a distclean and update and try again.

comment:5 Changed 6 years ago by EqUaTe

I can confirm this, and that libv4l still doesn't compile with current trunk.
Hasciicam can be fixed by updating to v1.1.1 release from the official site, rather than the ancient git-version presently being used. libv4l is replaced by v4l-utils.

comment:6 Changed 6 years ago by jogo

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed with r28997. Please open a separate ticket for libv4l/v4l-utils.

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.