Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9682 closed defect (duplicate)

trunk package 'less' missing dependency 'libncursesw'

Reported by: technozen Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Bug: 'less' missing libncursesw library package dependency

root@OpenWrt:~# mv /usr/bin/less /usr/bin/less_bb
root@OpenWrt:~# opkg install less
Installing less (436-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx[[BR]]
/packages/less_436-1_ar71xx.ipk.
Configuring less.
root@OpenWrt:~# less /etc/banner > /dev/null; echo $?
less: can't load library 'libncursesw.so.5'
16
root@OpenWrt:~#

Trivial workaround: install libncursesw manually

root@OpenWrt:~# opkg install libncursesw
Installing libncursesw (5.7-5) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx
/packages/libncursesw_5.7-5_ar71xx.ipk.
Configuring libncursesw.
root@OpenWrt:~#
root@OpenWrt:~# less /etc/banner > /dev/null; echo $?
0
root@OpenWrt:~# cat /etc/banner | grep bleeding
ATTITUDE ADJUSTMENT (bleeding edge, r27340) ----------

root@OpenWrt:~# ldd /usr/bin/less

libncursesw.so.5 => /usr/lib/libncursesw.so.5 (0x2ba2e000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2ba72000)
libc.so.0 => /lib/libc.so.0 (0x2ba94000)
ld-uClibc.so.0 => /lib/ld-uClibc.so.0 (0x2ba16000)

root@OpenWrt:~#

Fix: add 'libncursesw' (ncurses library with wide-character Unicode support) to the package dependency. Alternately, build 'less' binary with plain 8-bit character 'libncurses' instead(?)

cf. http://invisible-island.net/ncurses/ncurses.faq.html

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by technozen

related to /ticket/8787.html

(and agree building with libncursesw is better than libncurses)

comment:2 Changed 6 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8787.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.