Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9610 closed defect (fixed)

wifi does not start on trunk latest (r27279) on ar71xx with D-Link DIR615-C1

Reported by: Chillifire Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: wifi, hostapd, ath9k Cc: hanno.schupp@…

Description

Wifi came up fine on this platform and this router until yesterday with build r27279. Last good build prior to that was r27269. Now, after a variety of ath9k patches introduced between the two releases, wifi does not start anymore on this router. I find the following entries in logread:

Jun 25 01:52:35 Router002401331739 user.info sysinit: Configuration file: /var/run/hostapd-phy0.conf
Jun 25 01:52:35 Router002401331739 user.info sysinit: Line 45: unknown configuration item 'ieee80211n'
Jun 25 01:52:35 Router002401331739 user.info sysinit: Line 46: unknown configuration item 'ht_capab'
Jun 25 01:52:35 Router002401331739 user.info sysinit: 2 errors found in configuration file '/var/run/hostapd-phy0.conf'

When running 'wifi up' I get the same error messages.

/etc/config/wireless is standard generated by OpenWrt:

config wifi-device  radio0
	option type     mac80211
	option channel  11
	option macaddr	00:24:01:33:17:39
	option hwmode	11ng
	option htmode	HT20
	list ht_capab	SHORT-GI-40
	list ht_capab	DSSS_CCK-40

config wifi-iface
	option device   radio0
	option network  lan
	option mode     ap
	option ssid     OpenWrt
	option encryption none

I ran make distclean and make oldconfig on the .config profiles, but the error persists - ath9k wifi is broken. The break was likely introduced by the ath9k/mac80211 introduced between r27269 and r27279.

Please let me know, if you want me to run any further tests or provide more data.

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by Chillifire

I just reverted back to r27269 and lo, it is working again.
Guys, one of the ath9k patches must have broken wifi on r27269

comment:2 Changed 7 years ago by nbd

This is an issue with hostapd, not mac80211/ath9k

comment:3 follow-up: Changed 7 years ago by nbd

Please build latest, and post the output of ./scripts/diffconfig.sh then

comment:4 in reply to: ↑ 3 Changed 7 years ago by anonymous

Replying to nbd:

Please build latest, and post the output of ./scripts/diffconfig.sh then

OK, here goes the output of ./scripts/diffconfig.sh for my r27279 build as requested:

CONFIG_TARGET_ar71xx=y
CONFIG_TARGET_ar71xx_generic=y
CONFIG_TARGET_ar71xx_generic_DIR615C1=y
CONFIG_BUSYBOX_CONFIG_BLKID=y
# CONFIG_BUSYBOX_CONFIG_CMP is not set
CONFIG_BUSYBOX_CONFIG_DIFF=y
CONFIG_BUSYBOX_CONFIG_FEATURE_HAVE_RPC=y
CONFIG_BUSYBOX_CONFIG_FEATURE_MKSWAP_UUID=y
# CONFIG_BUSYBOX_CONFIG_FEATURE_MOUNT_HELPERS is not set
CONFIG_BUSYBOX_CONFIG_FEATURE_MOUNT_NFS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_EXT=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_FAT=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_HFS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_ISO9660=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_LINUXRAID=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_LINUXSWAP=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_NTFS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_REISERFS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_UDF=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VOLUMEID_XFS=y
CONFIG_BUSYBOX_CONFIG_KILLALL5=y
CONFIG_BUSYBOX_CONFIG_MKSWAP=y
CONFIG_BUSYBOX_CONFIG_SWAPONOFF=y
CONFIG_BUSYBOX_CONFIG_VOLUMEID=y
CONFIG_BUSYBOX_USE_LIBRPC=y
CONFIG_IMAGEOPT=y
CONFIG_PACKAGE_iptables-mod-conntrack-extra=y
CONFIG_PACKAGE_iptables-mod-extra=y
CONFIG_PACKAGE_iptables-mod-filter=y
CONFIG_PACKAGE_iptables-mod-ipopt=y
CONFIG_PACKAGE_iptables-mod-ulog=y
CONFIG_PACKAGE_kmod-ifb=y
CONFIG_PACKAGE_kmod-input-gpio-buttons=y
CONFIG_PACKAGE_kmod-ipt-conntrack-extra=y
CONFIG_PACKAGE_kmod-ipt-extra=y
CONFIG_PACKAGE_kmod-ipt-filter=y
CONFIG_PACKAGE_kmod-ipt-ipopt=y
CONFIG_PACKAGE_kmod-ipt-ulog=y
CONFIG_PACKAGE_kmod-sched=y
CONFIG_PACKAGE_kmod-textsearch=y
CONFIG_PACKAGE_kmod-tun=y
CONFIG_PACKAGE_libip6tc=y
CONFIG_PACKAGE_libiptc=y
CONFIG_PACKAGE_libltdl=y
CONFIG_PACKAGE_liblua=y
CONFIG_PACKAGE_libpthread=y
CONFIG_PACKAGE_librpc=y
CONFIG_PACKAGE_librt=y
CONFIG_PACKAGE_libuci-lua=y
CONFIG_PACKAGE_lua=y
CONFIG_PACKAGE_qos-scripts=y
CONFIG_PACKAGE_tc=y
CONFIG_PACKAGE_uhttpd=y
CONFIG_PACKAGE_zlib=y
CONFIG_UCI_PRECONFIG_network_lan_dns="8.8.8.8 8.8.4.4"
CONFIG_UCI_PRECONFIG_network_lan_ipaddr="192.168.12.1"
# CONFIG_B43_FW_4_150 is not set
# CONFIG_B43_FW_4_178 is not set
# CONFIG_B43_FW_5_10 is not set
# CONFIG_B43_OPENFIRMWARE is not set

comment:5 Changed 7 years ago by nbd

does your config with latest have CONFIG_DRIVER_11N_SUPPORT set?
does manually running make package/hostapd/clean; make and then reflashing to the new image fix the issue?

comment:6 Changed 7 years ago by anonymous

Yes, this was set.

make package/hostapd/clean
make

and then reflashing to the new image fixed the issue

Please close the ticket ( I cannot do this it seems )

comment:7 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.