Modify

Opened 7 years ago

Last modified 4 years ago

#9592 new task

first flash brinks?!!

Reported by: desigabri Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

hi, it happened to me almost three times to upgrade wr841nd_v7 from stock firmware and get the router bricked. I flashed my own firmware images so I thought to have made some mistakes. The previus time, I used the serial to unbrick the router reflashing a different version and it worked at the first moment. The last two routers It happend again so I had to solder the serial connectors and flash with tftp an older tested image, but it didn't work. tried doing a sysupgrade but it didn't work again. so found the boot log saying the jffs2 had problems:

"
Press the [f] key and hit [enter] to enter failsafe mode
eth0: link up (1000Mbps/Full duplex)

  • regular preinit -

jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00060000: 0x55aa instead
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0006000c: 0xb6ac instead
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0006012c: 0x74ea instead
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00060130: 0xde02 instead
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00060134: 0x74ea instead
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00060138: 0xde03 instead
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0006013c: 0x3ab3 instead
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00060140: 0x74ea instead
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00060144: 0xde05 instead
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00060148: 0x3ab3 instead
Further such events for this erase block will not be printed
Empty flash at 0x00060868 ends at 0x0006086c
Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes
empty_blocks 6, bad_blocks 0, c->nr_blocks 7
switching to jffs2

  • init -

"
the problem finally was that system couldn't write network config file so the router seemed briked.

Tried the comand "firstboot" and it unlocked the jffs2 filesystem so after that all worked well also after others new flashes.

Is it a forgotten command to add to any script into the firmware?
what could cause this problem?
It seems to be a serius trouble because it force you to solder the serial connector.

thanks in advance

Attachments (1)

errore boot jjfs2 doesn't working.txt (8.1 KB) - added by anonymous 7 years ago.
boot log with error

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by anonymous

boot log with error

comment:1 Changed 7 years ago by Jonathan Bennett <jbscience87@…>

I've observed this issue, too. It can be recovered without a serial connection, though. Use the button on the back of the router when booting to get into failsafe mode. Telnet into the router, and run firstboot. Reset, and it comes up as expected.

I will try to dig into the issue when I get a chance, but I'm not sure when I can get to it.

What revision of trunk is this that gives you the problem?

comment:2 Changed 7 years ago by desigabri

Well, I tryed again with trunk 27219 and 27246 compiled images.
I started from a dd-wrt firmware, then done a webrevert to stock firmware.
Al right so from stock firmware I flashed via web interface the openwrt firmware.
then the router became bricked troght LAN. It seemed to work but no response from LAN so I couldn't telnet to it.
Tryed an hard reset but the router didn't accept the hard reset: the router booted so I couldn't access to it again.
I was never able to switch to the openwrt failsafe state out of serial. But I tried to push one time and after a wyle others times pushing the reset button and the router became with the led flashing continuosly. So I tryed to ping and it magically responded. Telnetted and done a "firstboot" command, turned off and then on and it worked.

I'm sorry I always had problems getting the hard reset or recovery mode with u-boot without serial connection.

After that I searched the web about openwrt recovery mode and foud this.
I THINK IT SHOULD BE A MORE EXPLAINED AND USED WAY. IT WORKED AND I THINK IT WILL BE USEFULL TO ME FOR THE FUTURE. I read the wiki before but didn't realized about the failsafe mode. Googling for openwrt brick unbrick and so on, never get to me the suggestion of failsafe mode. Hope this will help other people

"Failsafe mode

If you forgot your password, broken one of the startup scripts, firewalled yourself or corrupted the JFFS2 partition, you can get back in by using OpenWrt's failsafe mode.
Boot into failsafe mode

Unplug the router's power cord.
Connect the router's LAN1 port directly to your PC.
Configure your PC with a static IP address between 192.168.1.2 and 192.168.1.254. E. g. 192.168.1.2 (gateway and DNS is not required.
Plug the power on and wait for the DMZ LED to light up. «But note that the RouterStation does not have a LED labeled DMZ. I hope someone can fix this»
While the DMZ LED is on immediately press any button (Reset and Secure Easy Setup will work) a few times . «It's not clear where there is a button to press. The RouterStation only has hardware button which is the reset button. »
If done right the DMZ LED will quickly flash 3 times every second.
You should be able to telnet to the router at 192.168.1.1 now (no username and password)

What to do in failsafe mode?

NOTE: The root file system in failsafe mode is the SquashFS partition mounted in readonly mode. To switch to the normal writable root file system run mount_root and make any changes. Run mount_root now.

Forgot/lost your password and you like to set a new one

passwd

Forgot the routers IP address

uci get network.lan.ipaddr

You accidentally run 'ipkg upgrade' or filled up the flash by installing to big packages (clean the JFFS2 partition and start over)

mtd -r erase rootfs_data If you are done with failsafe mode power cycle the router and boot in normal mode."


ANYWAY THEY HAVE TO KNOW THAT DOING THE FIRMWARE FLASH THEY CAN GET INTO THIS STUCK STATUS THAT NEEDS TO BE RESOLVED THROUGTH FAILSAFE OPENWRT BOOT

May be it depends on the trunk version or firmware compilation or others, I hope it will be resolved or cleared why it happened.

Thanks for answering Jonathan Bennett

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.