Modify

Opened 7 years ago

Last modified 7 years ago

#9531 accepted defect

Dual Broadcom radio with WPA2 doesn't work

Reported by: anonymous Owned by: jow
Priority: normal Milestone:
Component: packages Version: Backfire 10.03.1 RC4
Keywords: Dual Broadcom radio WPA WPA2 Cc:

Description

Backfire@27031 on WRT600N v1.1 using WRT610N profile (2.4 Kernel).

root/branches/backfire/package/broadcom-wl/files/lib/wifi/broadcom.sh

I had to change

[ -n "$nas" ] && nas="start-stop-daemon -S -b -x $nas -- "
killall -KILL nas >&- 2>&-

to

[ -n "$nas" ] #&& nas="start-stop-daemon -S -b -x $nas -- "
ps | awk '$5 ~ /(^|\/)nas$/ && $7 ~ /\/var\/run\/nas\.'"$device"'\.pid/{print $1}' | xargs kill >&- 2>&-

to make dual WPA2 work.

When using 5GHz

country ${country:-IL0}

causes the system to crash unless wireless.wl1.country is defined. Is it better to change it to

${country:+country $country}

to stop it crashing?

5GHz also complains about this line (but still works)

gmode ${hwmode:-1}

I changed it to

${hwmode:+gmode $hwmode}

to silence it.

Both 2.4GHz and 5GHz complain about this line (but still work)

rxant ${rxantenna:-3}

Removing the line can silence it.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

Add Comment

Modify Ticket

Action
as accepted .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.