Modify

Opened 7 years ago

Last modified 7 years ago

#9530 accepted defect

radvd and syslogd high CPU if started when WAN isn't fully up

Reported by: anonymous Owned by: jow
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: radvd Cc:

Description

Backfire@27031 on WRT600N v1.1 using WRT610N profile (2.4 Kernel).

I'm using the default config for 6to4 and radvd, OpenWRT's WAN is assigned a static public IP address and it's connected to a DOCSIS modem, when both devices are rebooted at the same time, the high CPU problem occurs, if OpenWRT is rebooted after the modem is fully up (properly connected to the ISP), the problem doesn't occur.

  PID  PPID USER     STAT   VSZ %MEM %CPU COMMAND
 1650     1 root     R     1088   4%  77% radvd -C /var/etc/radvd.conf -m stder
  147     1 root     R     1420   5%  23% syslogd -C16

The command below can fix the problem, but there should be a better solution

/etc/init.d/radvd reload

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

comment:2 Changed 7 years ago by anonymous

Another question about radvd.conf generated by 6to4.sh, should it advertise AdvLinkMTU if 6to4 interface has mtu defined?

comment:3 Changed 7 years ago by jow

Yes, but please lets keep things separated

Add Comment

Modify Ticket

Action
as accepted .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.