Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9529 closed defect (fixed)

sch_esfq.c "ifdef" causing hash type using conntrack not to work

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: esfq Cc:

Description

In build_dir/linux-brcm-2.4/linux-2.4.37.9/net/sched/sch_esfq.c , I had to remove "#ifdef CONFIG_IP_NF_CONNTRACK" to make ctnatchg hash type work, otherwise dmesg logs ESFQ: Unknown hash method. Falling back to classic.

Attachments (1)

config (46.0 KB) - added by anonymous 7 years ago.
config file from "make menuconfig"

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by anonymous

config file from "make menuconfig"

comment:1 Changed 7 years ago by anonymous

I don't know if the problem is caused by some packages not being included in the build, the config is attached.

The problem can be reproduced at compile time: edit sch_esfq.c, put uncompilable code in any of the #ifdef CONFIG_IP_NF_CONNTRACK sections, it still compiles which means CONFIG_IP_NF_CONNTRACK isn't defined, so all #ifdef CONFIG_IP_NF_CONNTRACK sections are ignored.

comment:2 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

split off into a separate package with a proper dependency in r32001

comment:3 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.