Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9513 closed defect (fixed)

Diag led always on after reboot on r27114 for WZR-HP-G300NH

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Was Changeset: r27043 meant to have DIAG led on even after a successful boot ?

r27114 fixed Tickets: #9488 but now DIAG led is not turned off after a bootup/reboot.

This happens even if sysupgrade do not save configuration over reflash.


Jun 6 15:42:17 OpenWrt user.info syslog: SNet version started
Jun 6 15:42:17 OpenWrt daemon.notice miniupnpd[1335]: HTTP listening on port 5000
Jun 6 15:42:17 OpenWrt daemon.err miniupnpd[1335]: chain MINIUPNPD not found
Jun 6 15:42:17 OpenWrt user.info sysinit: setting up led Wireless
Jun 6 15:42:17 OpenWrt user.info sysinit: setting up led Router
Jun 6 15:42:18 OpenWrt user.info sysinit: setting up led USB
Jun 6 15:42:18 OpenWrt daemon.info pppd[615]: CHAP authentication succeeded

BTW Upon reboot there is also an error regarding MINIUPNPD though upnp forwarding appear to work.

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by anonymous

It looks like this is by design.

/etc/diag.sh set_state() function is called by /etc/init.d/done and turn DIAG-led on using status_led_on()

This is kinda confusing as I understood wzr-hp-g300nh:red:diag was conventionally used for error/diagnostic and thus usually turned off.

Buffalo DIAG led reference, User manual, Page 9

comment:2 Changed 7 years ago by anonymous

It is possible to use /etc/config/system and have DIAG led turned off after boot

config 'led'
	option 'name' 'Diag'
	option 'sysfs' 'wzr-hp-g300nh:red:diag'
	option 'trigger' 'none'
	option 'default' '0'

This is possible because /etc/init.d/led is invoked after /etc/init.d/done

comment:3 Changed 7 years ago by anonymous

Fixed as of changeset:27341

comment:4 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

After discussing with Gabor, we decided to revert the original change to use the red diag LED, things should work like before now. See r27343.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.