Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9512 closed defect (worksforme)

kmod-gpio-dev not created

Reported by: n.lefalher@… Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: kmod-gpio-dev rdc Cc: 27114

Description

On Trunk, for Rdc/Bifferboard platform, "kmod-gpio-dev" is selected.
Gpio device support is selected in kernel_menuconfig.

No error at compilation, but package kmod-gpio-dev is not created.
So, there no device character /dev/gpio on running image.

Works if I test for a x86 platform.

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to accepted

rdc supports sysfs gpio, please use that instead of gpiodev. http://sites.google.com/site/bifferboard/Home/gpio

comment:2 Changed 7 years ago by anonymous

But if I want use /dev/gpio, for control it with ioctl ?

comment:3 Changed 7 years ago by florian

  • Resolution set to worksforme
  • Status changed from accepted to closed

I cannot reproduce the problem here with trunk and kernel 2.6.32:

ls bin/rdc/packages/kmod-gpio-dev_2.6.32.33-1_rdc.ipk
bin/rdc/packages/kmod-gpio-dev_2.6.32.33-1_rdc.ipk

comment:4 Changed 7 years ago by Nicolas Le Falher <n.lefalher@…>

Selected kmod-gpio-dev and Gpio device support dont make package.
If I select only kmod-gpio-dev its works.

$ ls bin/rdc/packages/ | grep gpio-dev
kmod-gpio-dev_2.6.32.20-1_rdc.ipk

Thanks.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.