Modify

Opened 7 years ago

Closed 6 years ago

#9486 closed defect (fixed)

Backfire RC5 (r27015) kernel dump

Reported by: kardy.rv@… Owned by: nbd
Priority: high Milestone: Backfire 10.03.1
Component: kernel Version: Trunk
Keywords: Cc:

Description

Hi folks.
It seems, that there is something seriously wrong with the ath9k and ath9k_htc modules. When i try to use 2 cards (PCI + USB) with Atheros chipsets the boot process fails (with a kernel dump) and the device becomes "unconnectable", but still responses to ping.

The idea is to connect with the USB card to a remote network and to setup a local network with the PCI card...

With the original broadcom (PCI) and ATH (USB) config are no issues. Except the "broadcom wifi disconnect under heavy load" issue, but thats another story...

Specs:
Asus WL500gP v1 without memory or clock tweaks
PCI: TP-Link TL-WN861N
USB: TP-Link TL-WN722N; TP-WN821N, without a USB hub, connected directly
Clean install of Backfire RC5 (r27015)

kmod-ath9k - 2.6.32.27+2011-04-19-3
kmod-ath9k-common - 2.6.32.27+2011-04-19-3
kmod-ath9k-htc - 2.6.32.27+2011-04-06-2
the ath9k_htc-2011-04-19-3 won't load (already logged)

Is there a "don't use 2 ATH cards limit" i don't know about?

Thanx, Kardy

Attachments (2)

putty.txt (13.7 KB) - added by kardy.rv@… 7 years ago.
kernel dump
RC6-r28680_ath9k-htc_issue.txt.txt (2.1 KB) - added by kardy.rv@… 6 years ago.
dmesg snips of the ath9k_htc boot behaviour with (dis)connected USB WiFi stick. Using the same HW as mentioned above.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by kardy.rv@…

kernel dump

comment:1 follow-up: Changed 7 years ago by jow

  • Owner changed from developers to nbd
  • Status changed from new to assigned

comment:2 in reply to: ↑ 1 Changed 7 years ago by kardy.rv@…

Replying to jow:

Hi jow.

I would like to expand on the "ath9k_htc won't load" comment. There is a ticket logged with this as well #9398. It seems, a bug has slipped in with kmod-ath9k-htc-2011-04-19-3 and is being "inherited" since :/.

Could it be, that there is something broken in the working (kmod-ath9k-htc-2.6.32.27+2011-04-06-2) version as well?

Cheers, Kardy
P.S.: Thanx for taking a look into it, should you need help or have questions, just ask.

comment:3 follow-up: Changed 6 years ago by hauke

Hi does this still occur with a recent trunk or backfire svn build?

Your error message looks like a bug in some part of the kernel please compile a kernel with "Compile the kernel with symbol table information" enabled and post the stacktrace again to see where this error is.

comment:4 in reply to: ↑ 3 Changed 6 years ago by anonymous

Replying to hauke:

Hi does this still occur with a recent trunk or backfire svn build?

Your error message looks like a bug in some part of the kernel please compile a kernel with "Compile the kernel with symbol table information" enabled and post the stacktrace again to see where this error is.

Hi.
I can confirm, that the 2 network card work OK now. Using BackFireRC6 r28680. Unfortunately, I get a "Target unresponsive" error after boot, when the USB stick is connected.
As i've found out, this is a know issue. The "connect after boot/reconnect after boot" workaround seem to work OK.
As far the original topic goes "2 Atheros cards are not working" we can consider is it closed.

Changed 6 years ago by kardy.rv@…

dmesg snips of the ath9k_htc boot behaviour with (dis)connected USB WiFi stick. Using the same HW as mentioned above.

comment:5 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

Please open up a new ticket for that.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.