Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9476 closed defect (duplicate)

Asus wl-500gpv2, 2.6 kernel, b43

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Backfire 10.03.1 RC4
Keywords: Cc:

Description (last modified by hauke)

Backfire (r24038)

using: http://downloads.openwrt.org/backfire/10.03.1-rc4/brcm47xx/openwrt-brcm47xx-squashfs.trx

Using default wifi-driver. System log below seems to indicate there's a problem with the wifi driver. The error comes after about 3 or 4 days uptime, sparingly using wifi (only for my smartphone).

Behavior: System load slowly rises, 1/3 of the processes indicate 3 to 5% load. memory begins to consume. Reboot from commandline doesn't reboot router (was already logged in, otherwise starting a new ssh session wouldn't work). Luci-reboot command won't reboot router either. Able to interact with luci for a while, until system load raises above 5.0. After a few more minutes, system load approaches 10 and system becomes non-responsive. must power-cycle router to recover.

Linux version 2.6.32.25 (openwrt@ampere) (gcc version 4.3.3 (GCC) ) #1 Fri Nov 19 22:01:56 PST 2010
CPU revision is: 00029029 (Broadcom BCM3302)
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x14, vendor 0x4243)
ssb: Core 1 found: Fast Ethernet (cc 0x806, rev 0x09, vendor 0x4243)
ssb: Core 2 found: MIPS 3302 (cc 0x816, rev 0x08, vendor 0x4243)
ssb: Core 3 found: USB 2.0 Host (cc 0x819, rev 0x02, vendor 0x4243)
ssb: Core 4 found: MEMC SDRAM (cc 0x80F, rev 0x04, vendor 0x4243)
ssb: Core 5 found: IEEE 802.11 (cc 0x812, rev 0x0D, vendor 0x4243)
ssb: Core 6 found: Roboswitch (cc 0x81C, rev 0x02, vendor 0x4243)
ssb: chipcommon status is 0x0
ssb: Found rev 0 PMU (capabilities 0x04A63400)
ssb: Initializing MIPS core...
ssb: set_irq: core 0x0806, irq 4 => 4
ssb: set_irq: core 0x0816, irq 5 => 2
ssb: set_irq: core 0x0812, irq 2 => 5
ssb: after irq reconfiguration
ssb: core 0x0800, irq : 2(S)  3* 4  5  6  D  I 
ssb: core 0x0806, irq : 2(S)  3  4* 5  6  D  I 
ssb: core 0x0816, irq : 2(S)* 3  4  5  6  D  I 
ssb: core 0x0819, irq : 2(S)  3  4  5  6* D  I 
ssb: core 0x080f, irq : 2(S)  3  4  5  6  D  I*
ssb: core 0x0812, irq : 2(S)  3  4  5* 6  D  I 
ssb: core 0x081c, irq : 2(S)  3  4  5  6  D  I*
ssb: Sonics Silicon Backplane found at address 0x18000000
Serial init done.
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00002000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00002000
On node 0 totalpages: 8192
free_area_init_node: node 0, pgdat 802a09f0, node_mem_map 81000000
  Normal zone: 64 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 8128 pages, LIFO batch:0
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
PID hash table entries: 128 (order: -3, 512 bytes)
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 2-way, VIPT, cache aliases, linesize 16 bytes
Memory: 29496k/32768k available (2331k kernel code, 3272k reserved, 356k data, 136k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:128
console [ttyS0] enabled
Calibrating delay loop... 239.61 BogoMIPS (lpj=479232)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 57
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 2 ports, IRQ sharing enabled
serial8250: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
serial8250.0: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250.0: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
flash init: 0x1c000000 0x02000000
Physically mapped flash: Found 1 x16 devices at 0x0 in 16-bit bank
Physically mapped flash: Found an alias at 0x800000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1000000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1800000 for the chip at 0x0
 CFI mfr 0x000000c2
 CFI id  0x000022cb
 Amd/Fujitsu Extended Query Table at 0x0040
  Amd/Fujitsu Extended Query version 1.1.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
Flash device: 0x800000 at 0x1fc00000
bootloader size: 131072
Creating 4 MTD partitions on "Physically mapped flash":
0x000000000000-0x000000020000 : "cfe"
0x000000020000-0x0000007f0000 : "linux"
0x0000000fb000-0x0000007f0000 : "rootfs"
mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2D0000, len=520000 
0x0000002d0000-0x0000007f0000 : "rootfs_data"
0x0000007f0000-0x000000800000 : "nvram"
b44.c:v2.0
eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:22:15:78:77:62
BCM47xx Watchdog Timer enabled (30 seconds, nowayout)
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 136k freed
Please be patient, while OpenWrt loads ...
diag: Detected 'ASUS WL-500g Premium V2'
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
roboswitch: Probing device eth0: found a 5325! It's a 5350.
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
b44: eth0: powering down PHY
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
device eth0.0 entered promiscuous mode
device eth0 entered promiscuous mode
br-lan: port 1(eth0.0) entering forwarding state
Compat-wireless backport release: compat-wireless-2010-10-14-7-gab01eca
Backport based on wireless-testing.git master-2010-10-19
cfg80211: Calling CRDA to update world regulatory domain
IMQ driver loaded successfully.
	Hooking IMQ before NAT on PREROUTING.
	Hooking IMQ after NAT on POSTROUTING.
b43-phy0: Broadcom 5354 WLAN found (core revision 13)
ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
Broadcom 43xx driver loaded [ Features: PL, GPIO LED Mask: 0x000f, Firmware-ID: FW13 ]
cfg80211: World regulatory domain updated:
    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Broadcom 43xx-legacy driver loaded [ Features: PLID, Firmware-ID: FW10 ]
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 24
nf_conntrack version 0.5.0 (463 buckets, 1852 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
xt_time: kernel timezone is -0000
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
device wlan0 left promiscuous mode
br-lan: port 2(wlan0) entering disabled state
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
b43-phy0 ERROR: DMA RX buffer too small (len: 42390, buffer: 2352, nr-dropped: 19)
b43-phy0 ERROR: DMA RX buffer too small (len: 25505, buffer: 2352, nr-dropped: 11)
b43-phy0 ERROR: DMA RX buffer too small (len: 19022, buffer: 2352, nr-dropped: 9)
b43-phy0 ERROR: DMA RX buffer too small (len: 4189, buffer: 2352, nr-dropped: 2)
b43-phy0 ERROR: DMA RX buffer too small (len: 37381, buffer: 2352, nr-dropped: 16)
skb_over_panic: text:80c9a408 len:2378 put:2378 head:80eef000 data:80eef040 tail:0x80eef98a end:0x80eef980 dev:<NULL>
Kernel bug detected[#1]:
Cpu 0
$ 0   : 00000000 1000b800 0000007c 00000001
$ 4   : 80293498 000020ed ffffffff 000020ed
$ 8   : 00004000 00000000 00000001 ffffffff
$12   : 0000000f 80253c78 ffffffff 00000000
$16   : 00eef040 0000092c 80eef040 819e0740
$20   : 81b3cb00 0000001e a1b4a1e0 80c9f978
$24   : 00000002 80166250                  
$28   : 81a46000 81a47db0 00000020 801a3d24
Hi    : 00000000
Lo    : 00000077
epc   : 801a3d24 0x801a3d24
    Not tainted
ra    : 801a3d24 0x801a3d24
Status: 1000b803    KERNEL EXL IE 
Cause : 00800024
PrId  : 00029029 (Broadcom BCM3302)
Modules linked in: xt_IMQ nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp xt_HL xt_hl xt_MARK ipt_ECN xt_CLASSIFY xt_time xt_tcpmss xt_statistic xt_mark xt_length ipt_ecn xt_DSCP xt_dscp xt_string xt_layer7 ipt_MASQUERADE iptable_nat nf_nat xt_CONNMARK xt_recent xt_helper xt_conntrack xt_connmark xt_connbytes xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc b43legacy sch_red b43 sch_sfq sch_hfsc cls_fw imq mac80211 ts_fsm ts_bm ts_kmp crc_ccitt cfg80211 compat_firmware_class compat arc4 aes_generic deflate ecb cbc switch_robo switch_core diag
Process irq/5-b43 (pid: 895, threadinfo=81a46000, task=81ab45d0, tls=00000000)
Stack : 00000000 80c9a408 0000094a 0000094a 80eef000 80eef040 80eef98a 80eef980
        8026e09c 0000001e a1b4a1e0 80c9a408 80c17ad4 00ff0000 000000e6 00010000
        819e2400 819e2400 80d31568 00ff0000 80c9f978 00010000 00010000 819e2400
        00008000 00010000 81b3ca24 00010000 802ce8c0 00000000 802953b4 80c872cc
        00010000 802ce8c0 80292f28 8001ce0c 819ea138 819ea138 80292f28 8001eba0
        ...
Call Trace:[<80c9a408>] 0x80c9a408
[<80c9a408>] 0x80c9a408
[<80c872cc>] 0x80c872cc
[<8001ce0c>] 0x8001ce0c
[<8001eba0>] 0x8001eba0
[<8001cef8>] 0x8001cef8
[<80190bf4>] 0x80190bf4
[<80c87424>] 0x80c87424
[<80057480>] 0x80057480
[<8000af98>] 0x8000af98
[<80057304>] 0x80057304
[<80057304>] 0x80057304
[<8003db30>] 0x8003db30
[<8000f86c>] 0x8000f86c
[<8003dab4>] 0x8003dab4
[<8000f85c>] 0x8000f85c


Code: afab001c  0c0028ff  afa20020 <0200000d> 08068f4a  00000000  8fbf002c  01201021  03e00008 
Disabling lock debugging due to kernel taint
exiting task "irq/5-b43" (895) is an active IRQ thread (irq 5)

Attachments (1)

kerrnel.log (10.2 KB) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by anonymous

comment:1 Changed 7 years ago by hauke

  • Description modified (diff)

comment:2 Changed 7 years ago by hauke

Could you please try trunk and check if this error also occurs there and then please build with symbol table information enabled.

comment:3 Changed 7 years ago by hauke

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #9459

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.