Modify

Opened 7 years ago

Closed 3 years ago

#9474 closed defect (moved_to_github)

transmission 2.31 open-file-limit always set to max 384

Reported by: Andrey Popov <admin@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: transmission 2.31 open file limit Cc:

Description

OpenWRT x86 trunk 27019

transmission 2.31 open-file-limit always set to max 384.

even if run ulimit -n 65535 and manualy edit settings.json. after start open-file-limit always set to max 384.

on previous version of transmission 2.22 I can set open-file-limit to 65535.

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by anonymous

The packaging of the between 2.22 and 2.31 has not changed much, so the problem may be in the same transmission.

comment:2 Changed 7 years ago by Andrey Popov <admin@…>

may be in transmission. I create ticket there https://trac.transmissionbt.com/ticket/4294[[BR]]
but openwrt transmission init.d script also contain:

config_get open_file_limit "$s" open_file_limit 32
let open_limit_files="$open_file_limit + 8"

if [ ${open_file_limit} -gt ${ulimit_files} ]; then
ulimit -n $open_limit_files
fi

comment:4 Changed 7 years ago by obsy

Try new 2.32. Release notes: Fix error caused by some "open-file-limit" configuration settings

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:6 Changed 3 years ago by jogo

  • Resolution set to moved_to_github
  • Status changed from new to closed

transmission has been moved to https://www.github.com/openwrt/packages. If this is still an issue, please open a ticket there.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.