Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9472 closed defect (no_response)

ath5k wds station can't reconnect

Reported by: duvi Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

AP: rb433uah, tp-link minipci wireless card, r27019, ath5k, wpad[full], wds on, psk-mixed encryption
STA: fonera, r26970, ath5k, wpad[full], wds on, psk2 encryption

After restarting the AP, the STA can not reconnect for a long time, sometimes minutes, sometimes never. If the STA is also rebooted, it reconnects immediately.

AP log shows nothing, STA log shows:

wlan0: direct probe to 00:19:e0:67:09:21 timed out
wlan0: direct probe to 00:19:e0:67:09:21 (try 1/3)
wlan0: direct probe to 00:19:e0:67:09:21 (try 2/3)
wlan0: direct probe to 00:19:e0:67:09:21 (try 3/3)
wlan0: direct probe to 00:19:e0:67:09:21 timed out
wlan0: direct probe to 00:19:e0:67:09:21 (try 1/3)
wlan0: direct probe to 00:19:e0:67:09:21 (try 2/3)
wlan0: direct probe to 00:19:e0:67:09:21 (try 3/3)
wlan0: direct probe to 00:19:e0:67:09:21 timed out

while it's not connecting, and when finally connecting:

wlan0: authenticate with 00:19:e0:67:09:21 (try 1)
wlan0: authenticated
wlan0: associate with 00:19:e0:67:09:21 (try 1)
wlan0: RX AssocResp from 00:19:e0:67:09:21 (capab=0x411 status=0 aid=2)
wlan0: associated
br-lan: port 2(wlan0) entering forwarding state
br-lan: port 2(wlan0) entering forwarding state

ps: I have 2 STA with the same config, one has reconnected as shown above, the other has still not reconnected (it should probably be rebooted).

Attachments (0)

Change History (10)

comment:1 Changed 7 years ago by duvi

AP config:

config wifi-device  radio0
        option disabled 0
        option type     mac80211
        option channel  1
        option macaddr  00:19:e0:67:09:21
        option hwmode   11g

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option wds      1
        option ssid     myssid
        option encryption psk-mixed
        option key      password
        option wpa_group_rekey 3600

STA config

config wifi-device  radio0
        option type     mac80211
        option channel  1
        option macaddr  00:18:84:24:62:3d
        option hwmode   11g
        option disabled 0

config wifi-iface
        option device   radio0
        option network  lan
        option mode     sta
        option wds      1
        option ssid     myssid
        option encryption psk2
        option key      password

comment:2 Changed 7 years ago by nbd

please test r27024

comment:3 Changed 7 years ago by jow

  • Milestone changed from Attitude Adjustment (trunk) to Backfire 10.03.1

comment:4 Changed 7 years ago by jow

  • Milestone changed from Backfire 10.03.1 to Attitude Adjustment (trunk)

mistakenly assigned for backfire, changing back to trunk

comment:5 Changed 7 years ago by duvi

AP and stations upgraded to r27025, but I'm still seeing the same thing.

The AP also has an ath9k card, using that it's all the same. This means to me that the problem is within the ath5k stations.

comment:6 Changed 7 years ago by duvi

Still the same issue, same config, r27439 on all devices.
AP and 3 WDS Stations are all Fonera.
Log shows on the station

ATTITUDE ADJUSTMENT (bleeding edge, r27439) ----------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:~# logread
Jul  4 15:32:12 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 timed out
Jul  4 15:32:17 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 (try 1/3)
Jul  4 15:32:17 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 (try 2/3)
Jul  4 15:32:17 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 (try 3/3)
Jul  4 15:32:17 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 timed out
Jul  4 15:32:23 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 (try 1/3)
Jul  4 15:32:23 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 (try 2/3)
Jul  4 15:32:23 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 (try 3/3)
Jul  4 15:32:23 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 timed out
Jul  4 15:32:29 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 (try 1/3)
Jul  4 15:32:29 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 (try 2/3)
Jul  4 15:32:29 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 (try 3/3)
Jul  4 15:32:29 OpenWrt kern.debug kernel: wlan0: direct probe to 00:18:84:2a:e2:59 timed out

for a long time...

Then I run /etc/init.d/network restart on the station, and it immediately connects

Jul  4 15:37:37 OpenWrt kern.info kernel: device wlan0 entered promiscuous mode
Jul  4 15:37:37 OpenWrt kern.debug kernel: wlan0: authenticate with 00:18:84:2a:e2:59 (try 1)
Jul  4 15:37:37 OpenWrt kern.debug kernel: wlan0: authenticated
Jul  4 15:37:37 OpenWrt kern.debug kernel: wlan0: associate with 00:18:84:2a:e2:59 (try 1)
Jul  4 15:37:38 OpenWrt kern.debug kernel: wlan0: RX AssocResp from 00:18:84:2a:e2:59 (capab=0x411 status=0 aid=4)
Jul  4 15:37:38 OpenWrt kern.debug kernel: wlan0: associated

comment:7 Changed 7 years ago by nbd

please try the latest version, the channel change fix might have fixed this

comment:8 Changed 6 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:9 Changed 6 years ago by duvi

Yes, thanks, it's been working for a while.
Sorry for no response.

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.