Modify

Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#9452 closed defect (fixed)

xmail crashes tl-wr1043ns on startup

Reported by: Steve Borilla Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Crash, xmail, tl-wr1043nd Cc:

Description

Starting xmail (compiled from trunk) crashes and reboots the router:

root@OpenWrt:/home/MailRoot# /etc/init.d/xmail start
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number

Afterwards the router reboots.

Attachments (1)

xmail-empty_flags_fix.patch (474 bytes) - added by НКВД 6 years ago.
Patch to fix the "sh: bad number" errors in xmail init script

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by anonymous

This problem (lots of "sh: bad number"; not the system crash) has the same nature with this one. With that, XMail is executed with ALL options enabled (which is VERY memory hungry, thus invoking the oom-killer)

root@nkvd:~# /etc/init.d/xmail start
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
sh: bad number
root@nkvd:~# 

And the resulting command line is:

/usr/bin/XMail -Ms /path/to/MailRoot -Md -MM -Mm -M4 -M6 -M5 -M7 -P- -P6 -Pl -Ph -PX 4 -B- -B6 -S- -S6 -Sl -SX 4 -X- -X6 -Qn 8 -Ql -Qg -Y- -Yl -F- -F6 -Fl -C- -C6 -Cl -W- -W6 -Ln 4 -Ll

Without the error, XMail is executed only with the options enabled in the config file (/etc/config/xmail).

root@nkvd:~# /etc/init.d/xmail start
root@nkvd:~# 

And the resulting command line is:

/usr/bin/XMail -Ms /path/to/MailRoot -PX 4 -B- -SX 4 -X- -Qn 8 -Y- -F- -W- -Ln 4

Changed 6 years ago by НКВД

Patch to fix the "sh: bad number" errors in xmail init script

comment:2 Changed 6 years ago by caog

I can verify this problem.
Rather annoying but simple fix as posted by НКВД.

comment:3 Changed 6 years ago by claus

I'm using trunk ( r32689 ) and I'm able to confirm this bug as well and I can confirm that the patch from НКВД ( https://dev.openwrt.org/raw-attachment/ticket/9452/xmail-empty_flags_fix.patch ) works.

comment:4 Changed 5 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with r33058

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.