Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9398 closed defect (no_response)

Nice work on ath9k-htc

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

Now this is the only message i get when i insert an atheros ar9271 in the usb port: " new high speed USB device using ehci_hcd and address "

...and that's all. trunk 26846

Attachments (0)

Change History (9)

comment:1 follow-up: Changed 7 years ago by jow

  • Component changed from packages to kernel
  • Priority changed from normal to response-needed

On which platfrom using which hardware? Custom build or from snapshots? Which modules are loaded? Is USB 2.0 confirmed working with other devices?

comment:2 in reply to: ↑ 1 Changed 7 years ago by anonymous

Replying to jow:

On which platfrom using which hardware? Custom build or from snapshots? Which modules are loaded? Is USB 2.0 confirmed working with other devices?

Usb2 and uhci installed. It's seeing perfectly a flash memory.

brcm47xx on asus wl-500gp v1 (no wifi card in minipci slot). Trunk 26846 it's a snapshot, isn't it?!

Modules: kmod-usb-storage kmod-usb-uhci kmod-usb2 mc fdisk kmod-ath9k kmod-ath9k-htc kmod-madwifi openssh-sftp-server

comment:3 Changed 7 years ago by anonymous

Not really, no.

ath9k_htc: Unknown symbol ath9k_htc_init_debug (err 0)
ath9k_htc: Unknown symbol ath9k_htc_err_stat_rx (err 0)

comment:4 Changed 7 years ago by anonymous

Any USB device will say that. Does the module load without error? Are you able to configure and bring up the interface?

comment:5 Changed 7 years ago by tom

looks like the ath9k_htc module is broken, while trying to load the module, I get the following error:

:/# insmod /lib/modules/2.6.37.6/ath9k_htc.ko
ath9k_htc: Unknown symbol ath9k_htc_init_debug (err 0)
ath9k_htc: Unknown symbol ath9k_htc_err_stat_rx (err 0)
insmod: can't insert '/lib/modules/2.6.37.6/ath9k_htc.ko': unknown symbol in module, or unknown parameter

version(r26949)

comment:6 Changed 7 years ago by anonymous

I can confirm, tested on WL500gP v1, with TL-WN722N and TL-WN821N. In both cases only the previously mentioned error appears. Using trunk r26970.

However the issue does not seem to be appear with
kmod-ath9k-htc_2.6.32.27+2011-04-06-2_brcm47xx (build on 16-Apr)
But ANYTHING newer is affected (seems so)... :/

comment:7 Changed 6 years ago by hauke

Does this error still occur with a recent trunk or backfire svn build?

comment:8 Changed 6 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.