Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9371 closed defect (no_response)

tcpdump consumes 100% CPU utilization

Reported by: Raghu Pobbi Venkatachalapathy <raghupv30@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I have got the openwrt trunk firmware executing on Atheros based TpLink WR1043ND and Linksys WRT160NL and WNDR3700.
The tcpdump application when executed on either of these devices, consumes 100% CPU.
Any application using libpcap (emulating tcpdump) does also consume 100% CPU
This has been the case even if there is less traffic to sniff on any of the interfaces.

root@OpenWrt:/tmp# ls -ltr /usr/lib/libpcap.s*
-rw-r--r-- 1 root root 179368 Apr 21 16:04 /usr/lib/libpcap.so.1.0.0
lrwxrwxrwx 1 root root 16 Apr 27 10:09 /usr/lib/libpcap.so.1.0 -> libpcap.so.1.0.0
lrwxrwxrwx 1 root root 14 Apr 27 10:09 /usr/lib/libpcap.so -> libpcap.so.1.0

The CPU speed on these devices range between 400Mhz to 680Mhz and should suffice to run an application like tcpdump.

Note that the three devices referred here (WR1043ND, Linksys WRT160NL , WNDR3700) are all are Atheros based.
I had a chance to test tcpdump on a similar CPU speed device Netgear WNR3500L (running DDWRT firm,ware), which is Broadcom based where no spikes or high utilization was seen.
I might be wrong but I strongly believe its the problem with the openwrt firmware for Atheros based devices...

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by anonymous

From my experience, it only happens with libpcap versions > 1.x

comment:2 Changed 7 years ago by nbd

please try latest trunk, the libpcap update should have fixed this and i cannot reproduce the issue here.

comment:3 Changed 7 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.