Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9370 closed defect (fixed)

Poor performance with ath9k under trunk r26836

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

with trunk r26836, the wireless trasfer speed can only up to 70KB/s between two ar9160, with trunk r26798, the the wireless trasfer speed can get 6.XMB/s.

Attachments (0)

Change History (15)

comment:1 Changed 7 years ago by nbd

Please copy http://nbd.name/580-ath9k_nf_cal_fix.patch to package/mac80211/patches, rebuild, and see if that fixes the problem.

comment:2 follow-up: Changed 7 years ago by anonymous

I tried 580-ath9k_nf_cal_fix.patch, but no use.

comment:3 in reply to: ↑ 2 Changed 7 years ago by anonymous

Replying to anonymous:

I tried 580-ath9k_nf_cal_fix.patch, but no use.

and worst going, now can only up to 10KB/s

comment:4 Changed 7 years ago by nbd

how about http://nbd.name/580-ath9k_nf_cal_revert.patch (instead of the other one)

comment:5 Changed 7 years ago by anonymous

I reboot the wireless router, and now:

wlan0     IEEE 802.11abgn  ESSID:"mywl"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:03:7F:0C:E3:26   
          Bit Rate=270 Mb/s   Tx-Power=27 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1855   Missed beacon:0

the transfer speed is up to 100KB/s.
now, I'll try 580-ath9k_nf_cal_revert.patch.

comment:6 Changed 7 years ago by anonymous

I have tried 580-ath9k_nf_cal_revert.patch , now:

wlan0     IEEE 802.11abgn  ESSID:"mywl"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:03:7F:0C:E3:26   
          Bit Rate=270 Mb/s   Tx-Power=27 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=64/70  Signal level=-46 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:96   Missed beacon:0

but the transfer speed still can only reach 120KB/s. with trunk r26846. I test transfer speed with vsftpd and flashfxp, and transfer a file to /tmp directory.

comment:7 Changed 7 years ago by nbd

The last patch that I gave you reverts ath9k back to the state from r26798. Are you sure that there is actually a performance difference between r26798 and r26846?
My guess is either something in the environment (or your configuration) changed to trigger this, or the problem is unrelated to mac80211/ath9k.

Did you try building the older version again to see if it gets the speed back up to a few MB/s?

comment:8 Changed 7 years ago by anonymous

I'am sure it is not a environment or configuration problem.
I'll try later to rebuild the r26798 version again and see if it still gets the speed to 6.XMB/s. but I guess the wireless speed will still have problem after rebuild a r26798 version now. I doubt maybe the problem is unrelated to mac80211/ath9k too.

this is my former experience and ticket. /ticket/9083.html

comment:9 Changed 7 years ago by jeyjay

I can confirm that the speed is poor (currently testing r26878). Maximum speed I can get is around 5Mbit/s with 11bgn enabled. Using 11g only mode I get a wireless speed of around 16Mbit/s.

The best results I have ever achieved was with r26744 (or a few revisions before that). By using this revision I got up to 21Mbit/s (11bgn mode) using my plain old 11g network card.

comment:10 Changed 7 years ago by nbd

Could you please test the older versions again and figure out which revision *exactly* caused the throughput drop? That would help me a lot with the code review.

Thanks

comment:11 Changed 7 years ago by jeyjay

Speed is better with r27004 in 11g+n mode. I can reach up to 17Mbit/s. But there is still room left for improvements.

At the moment I have no time to test older revisions. Anyway I'm still struggling with disconnects (ticket 8446). In my opinion this is a greater problem.

comment:12 Changed 7 years ago by nbd

please try latest trunk

comment:13 Changed 7 years ago by jeyjay

Performance is back to normal at least for my 11g card connected to my 11n router.

Anyway, no more complaints for weeks so I would suggest to close this ticket.

I think you changed quite a lot of code in the trunk so this ticket isn't anymore related to current trunk. A user can easily open a new ticket if something is broken.

comment:14 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:15 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.