Modify

Opened 7 years ago

Closed 5 years ago

#9347 closed defect (duplicate)

Backfire (r26799), x86, mdadm compile error

Reported by: onokonem@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Backfire 10.03
Keywords: Cc:

Description

make[3]: Entering directory `/build/fwwrt/backfire/feeds/packages/utils/mdadm'
make -C /build/fwwrt/backfire/build_dir/target-i386_uClibc-0.9.30.1/mdadm-3.2 CC="i486-openwrt-linux-uclibc-gcc" CFLAGS="-O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts -DUCLIBC -DHAVE_STDINT_H" LDFLAGS="-L/build/fwwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/usr/lib -L/build/fwwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/lib -L/build/fwwrt/backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/usr/lib -L/build/fwwrt/backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/lib" mdadm mdassemble
make[4]: Entering directory `/build/fwwrt/backfire/build_dir/target-i386_uClibc-0.9.30.1/mdadm-3.2'
i486-openwrt-linux-uclibc-gcc -L/build/fwwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/usr/lib -L/build/fwwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/lib -L/build/fwwrt/backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/usr/lib -L/build/fwwrt/backfire/staging_dir/toolchain-i386_gcc-4.1.2_uClibc-0.9.30.1/lib -o mdadm mdadm.o config.o policy.o mdstat.o  ReadMe.o util.o Manage.o Assemble.o Build.o Create.o Detail.o Examine.o Grow.o Monitor.o dlink.o Kill.o Query.o Incremental.o mdopen.o super0.o super1.o super-ddf.o super-intel.o bitmap.o super-mbr.o super-gpt.o restripe.o sysfs.o sha1.o mapfile.o crc32.o sg_io.o msg.o platform-intel.o probe_roms.o 
Grow.o: In function `child_monitor':
Grow.c:(.text+0x2a6b): undefined reference to `posix_memalign'
Grow.c:(.text+0x31db): undefined reference to `posix_memalign'
Grow.c:(.text+0x36cd): undefined reference to `posix_memalign'
super0.o: In function `compare_super0':
super0.c:(.text+0x8d0): undefined reference to `posix_memalign'
super0.o: In function `init_super0':
super0.c:(.text+0x207e): undefined reference to `posix_memalign'
super0.o:super0.c:(.text+0x2414): more undefined references to `posix_memalign' follow
platform-intel.o: In function `devt_to_devpath':
platform-intel.c:(.text+0xf1): undefined reference to `canonicalize_file_name'
platform-intel.o: In function `find_driver_devices':
platform-intel.c:(.text+0x4ae): undefined reference to `canonicalize_file_name'
collect2: ld returned 1 exit status
make[4]: *** [mdadm] Error 1
make[4]: Leaving directory `/build/fwwrt/backfire/build_dir/target-i386_uClibc-0.9.30.1/mdadm-3.2'
make[3]: *** [/build/fwwrt/backfire/build_dir/target-i386_uClibc-0.9.30.1/mdadm-3.2/.built] Error 2
make[3]: Leaving directory `/build/fwwrt/backfire/feeds/packages/utils/mdadm'
make[2]: *** [package/feeds/packages/mdadm/compile] Error 2
make[2]: Leaving directory `/build/fwwrt/backfire'
make[1]: *** [/build/fwwrt/backfire/staging_dir/target-i386_uClibc-0.9.30.1/stamp/.package_compile] Error 2
make[1]: Leaving directory `/build/fwwrt/backfire'
make: *** [world] Error 2

Host: Debian 6.0.1

Attachments (1)

dot.config (109.2 KB) - added by onokonem@… 7 years ago.
.config

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by onokonem@…

.config

comment:1 Changed 7 years ago by anonymous

Seems to be a duplicate of #9306.

comment:2 Changed 5 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9306.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.