Modify

Opened 7 years ago

Last modified 4 years ago

#9334 new defect

Add zlib bzip2 config to boost

Reported by: joostrietdijk@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

When compiled boost package without boost-iostreams I get an error with bzip2 package. I think it is better to check at the config if zlib or bzip2 is selected.

Attachments (2)

boost.patch (1.0 KB) - added by anonymous 7 years ago.
boost1.patch (942 bytes) - added by Joost <joostrietdijk@…> 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by anonymous

comment:1 Changed 7 years ago by jow

This kind of conditional compilation is not acceptable as the actual features of the resulting binary are somewhat unpredictable (./scripts/feeds install -d m boost would have less features than boost compiled in an environment with bzip2 and gzip enabled...)

comment:2 Changed 7 years ago by Joost <joostrietdijk@…>

Ok, so we need set always the zlib include path? (see boost1.patch)

Changed 7 years ago by Joost <joostrietdijk@…>

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.