Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9313 closed defect (duplicate)

Kernel crashes in trunk(r26751)

Reported by: ricetons@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: ath9k Cc:

Description

I'm using TPlink TR841N V5 (AR9280). I saw the following traces in dmesg:

Jan  1 00:02:33 OpenWrt kern.warn kernel: ------------[ cut here ]------------
Jan  1 00:02:33 OpenWrt kern.warn kernel: WARNING: at net/sched/sch_generic.c:258 0x801df124()
Jan  1 00:02:33 OpenWrt kern.info kernel: NETDEV WATCHDOG: eth1 (ag71xx): transmit queue 0 timed out
Jan  1 00:02:33 OpenWrt kern.warn kernel: Modules linked in: ohci_hcd ledtrig_usbdev nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_conntrack xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci
Jan  1 00:02:33 OpenWrt kern.warn kernel: Call Trace:[<8025733c>] 0x8025733c
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<8025733c>] 0x8025733c
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<80074b00>] 0x80074b00
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<801df124>] 0x801df124
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<80074bb4>] 0x80074bb4
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<801ce4d0>] 0x801ce4d0
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<801df124>] 0x801df124
Jan  1 00:02:33 OpenWrt kern.info kernel: eth1: link up (100Mbps/Half duplex)
  1. A little bit of research indicates the bug might be a regression. (see ticket #6754, #7131).
  1. It doesn't seem to happen on backfire 10.03.1-rc4.
  1. The wan port is still usable after the crash.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by ricetons@…

Here is the full trace

------------[ cut here ]------------
WARNING: at net/sched/sch_generic.c:258 0x801df124()
NETDEV WATCHDOG: eth1 (ag71xx): transmit queue 0 timed out
Modules linked in: ohci_hcd ledtrig_usbdev nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_conntrack xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci_hcd pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k ath9k_common ath9k_hw ath mac80211 usbcore nls_base crc_ccitt cfg80211 compat arc4 aes_generic crypto_algapi leds_gpio button_hotplug gpio_keys_polled input_polldev input_core
Call Trace:[<8025733c>] 0x8025733c
[<8025733c>] 0x8025733c
[<80074b00>] 0x80074b00
[<801df124>] 0x801df124
[<80074bb4>] 0x80074bb4
[<801ce4d0>] 0x801ce4d0
[<801df124>] 0x801df124
[<80086afc>] 0x80086afc
[<801defb8>] 0x801defb8
[<8007eb84>] 0x8007eb84
[<80067f1c>] 0x80067f1c
[<801c7eb8>] 0x801c7eb8
[<8007a168>] 0x8007a168
[<802da0b0>] 0x802da0b0
[<8007a260>] 0x8007a260
[<8006214c>] 0x8006214c
[<80062320>] 0x80062320
[<802da0b0>] 0x802da0b0
[<8006139c>] 0x8006139c
[<80063ccc>] 0x80063ccc
[<80062340>] 0x80062340
[<802bb8c0>] 0x802bb8c0
[<802da0b0>] 0x802da0b0
[<802bb21c>] 0x802bb21c

---[ end trace e6fbe38a152ec12d ]---

comment:2 Changed 7 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #9312

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.