Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9312 closed defect (fixed)

Kernel crashes in trunk(r26751)

Reported by: ricetons@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: ath9k Cc:

Description

I'm using TPlink TR841N V5 (AR9280). I saw the following traces in dmesg:

Jan  1 00:02:33 OpenWrt kern.warn kernel: ------------[ cut here ]------------
Jan  1 00:02:33 OpenWrt kern.warn kernel: WARNING: at net/sched/sch_generic.c:258 0x801df124()
Jan  1 00:02:33 OpenWrt kern.info kernel: NETDEV WATCHDOG: eth1 (ag71xx): transmit queue 0 timed out
Jan  1 00:02:33 OpenWrt kern.warn kernel: Modules linked in: ohci_hcd ledtrig_usbdev nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_conntrack xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci
Jan  1 00:02:33 OpenWrt kern.warn kernel: Call Trace:[<8025733c>] 0x8025733c
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<8025733c>] 0x8025733c
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<80074b00>] 0x80074b00
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<801df124>] 0x801df124
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<80074bb4>] 0x80074bb4
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<801ce4d0>] 0x801ce4d0
Jan  1 00:02:33 OpenWrt kern.warn kernel: [<801df124>] 0x801df124
Jan  1 00:02:33 OpenWrt kern.info kernel: eth1: link up (100Mbps/Half duplex)
  1. A little bit of research indicates the bug might be a regression. (see ticket #6754, #7131).
  1. It doesn't seem to happen on backfire 10.03.1-rc4.
  1. The wan port is still usable after the crash.

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by ricetons@…

Sorry, it seems that my browser submit the ticket twice. It's a duplicate of #9313.

comment:2 Changed 7 years ago by ricetons@…

I confirmed that the bug exists in 10.03.1-rc5, but not in 10.03.1-rc4.

After the crash, the WAN port jumps up and down:

Mar 26 21:46:42 OpenWrt user.debug kernel: eth1: tx timeout
Mar 26 21:46:42 OpenWrt user.info kernel: eth1: link up (100Mbps/Half duplex)
Mar 26 21:46:58 OpenWrt user.info kernel: eth1: link up (100Mbps/Full duplex)
Mar 26 21:47:00 OpenWrt user.info kernel: eth1: link up (100Mbps/Half duplex)
Mar 26 21:47:08 OpenWrt user.debug kernel: eth1: tx timeout
Mar 26 21:47:08 OpenWrt user.info kernel: eth1: link up (100Mbps/Full duplex)
Mar 26 21:47:10 OpenWrt user.info kernel: eth1: link up (100Mbps/Half duplex)
Mar 26 21:47:18 OpenWrt user.info kernel: eth1: link up (100Mbps/Full duplex)
Mar 26 21:47:20 OpenWrt user.info kernel: eth1: link up (100Mbps/Half duplex)
Mar 26 21:47:28 OpenWrt user.info kernel: eth1: link up (100Mbps/Full duplex)
Mar 26 21:47:32 OpenWrt user.info kernel: eth1: link up (100Mbps/Half duplex)
Mar 26 21:47:34 OpenWrt user.debug kernel: eth1: tx timeout
Mar 26 21:47:34 OpenWrt user.info kernel: eth1: link up (100Mbps/Full duplex)
Mar 26 21:47:36 OpenWrt user.info kernel: eth1: link up (100Mbps/Half duplex)
Mar 26 21:47:38 OpenWrt user.info kernel: eth1: link up (100Mbps/Full duplex)
Mar 26 21:47:46 OpenWrt user.info kernel: eth1: link up (100Mbps/Half duplex)
Mar 26 21:47:50 OpenWrt user.debug kernel: eth1: tx timeout
Mar 26 21:47:52 OpenWrt user.info kernel: eth1: link up (100Mbps/Full duplex)
Mar 26 21:47:54 OpenWrt user.info kernel: eth1: link up (100Mbps/Half duplex)

comment:3 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

has been fixed in trunk for a while, fix backported to backfire in r26985

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.