Modify

Opened 7 years ago

Closed 7 years ago

#9306 closed defect (fixed)

Error compiling madm after update in last Backfire

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: Cc:

Description

mips_r2_uClibc-0.9.30.1/lib -L/opt/projekty/openwrt/ar71xx-backfire/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/usr/lib -L/opt/projekty/openwrt/ar71xx-backfire/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/lib -o mdadm mdadm.o config.o policy.o mdstat.o  ReadMe.o util.o Manage.o Assemble.o Build.o Create.o Detail.o Examine.o Grow.o Monitor.o dlink.o Kill.o Query.o Incremental.o mdopen.o super0.o super1.o super-ddf.o super-intel.o bitmap.o super-mbr.o super-gpt.o restripe.o sysfs.o sha1.o mapfile.o crc32.o sg_io.o msg.o platform-intel.o probe_roms.o 
Grow.o: In function `child_monitor':
Grow.c:(.text+0x345c): undefined reference to `posix_memalign'
Grow.c:(.text+0x4840): undefined reference to `posix_memalign'
Grow.c:(.text+0x485c): undefined reference to `posix_memalign'
super0.o: In function `load_super0':
super0.c:(.text+0xaa0): undefined reference to `posix_memalign'
super0.o: In function `compare_super0':
super0.c:(.text+0xd80): undefined reference to `posix_memalign'
super0.o:super0.c:(.text+0x1154): more undefined references to `posix_memalign' follow
platform-intel.o: In function `devt_to_devpath':
platform-intel.c:(.text+0x100): undefined reference to `canonicalize_file_name'
platform-intel.o: In function `find_driver_devices':
platform-intel.c:(.text+0x514): undefined reference to `canonicalize_file_name'
collect2: ld returned 1 exit status

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by ciusss89 <ciusss@…>

Try 'make dirclean' e 'make clean'

comment:2 Changed 7 years ago by anonymous

No, fresh chceckout from svn.

comment:3 Changed 7 years ago by admin@…

Hi,

Totally agree with this issue.

Back to r26754 compiles fine. Therefore, the issue is linked to r26755 (update of mdadm 2.6.7.2 => 3.2).

FYI, last release (r27172) still not compile.

Thanks a lot
Nicolas

comment:4 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.