Modify

Opened 7 years ago

Closed 6 years ago

#9293 closed defect (fixed)

wshaper 'tc filter add' call returns ENOENT

Reported by: jlayton@… Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: packages Version: Trunk
Keywords: wshaper Cc:

Description

Near the end of the script, wshaper.htp runs this command and gets the following error:

+ tc filter add dev eth1 parent ffff: protocol ip prio 50 u32 match ip src 0.0.0.0/0 police rate 8000kbit burst 10k drop flowid :1
RTNETLINK answers: No such file or directory
We have an error talking to the kernel

...the problem is that the script does not plug in act_police.ko at startup. This is my package version:

# opkg list_installed wshaper
wshaper - 0.1

My openwrt version is 10.03.1-rc5-testing snapshot from April 11, 2011.

I don't have a SVN checkout to prepare a proper patch, but this is the MODULES line in my fixed script:

MODULES='sch_ingress sch_sfq sch_htb cls_u32 act_police'

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with r28454, r28455

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.