Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9287 closed defect (fixed)

subversion-server not working

Reported by: rincewind Owned by: nico
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: subversion-server Cc:

Description

This error occurs when trying to commit something to svn:

$ svn mkdir test
A         test
$ svn commit test -m "some text"
Hinzufügen     test
svn: Übertragen schlug fehl (Details folgen):
svn: Corrupt node-revision '0.0.t0-2'
svn: Malformed text representation offset line in node-rev

My current firmware version is: OpenWrt Firmware Attitude Adjustment (r26716) / LuCI Trunk 0.10+svn6987

I have a D-Link DIR-825 rev. B1. (architecture ar71xx)

This might be causing the problem: http://mail-archives.apache.org/mod_mbox/subversion-users/201101.mbox/%3C66B14FB7D5784002A4AF53A7888B641D@Brostykkevej2%3E

The issue is discussed in the forum here: https://forum.openwrt.org/viewtopic.php?pid=133795#p133795

Developer jow said it could be introduced by the new Linaro gcc.

Please let me know if i should add more information.

Attachments (1)

subversion-libs_1.6.16-2_ar71xx.ipk (567.4 KB) - added by rincewind 7 years ago.
updated version of subversion-libs by coolslob

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by rincewind

updated version of subversion-libs by coolslob

comment:1 Changed 7 years ago by rincewind

solved. the package from coolslob solves the problem. he modified it according to http://mail-archives.apache.org/mod_mbox/subversion-users/201101.mbox/%3C66B14FB7D5784002A4AF53A7888B641D@Brostykkevej2%3E

comment:2 follow-up: Changed 7 years ago by florian

So how do we fix this problem?

comment:3 Changed 7 years ago by lintel.huang@…

This problem is still not resolved in trunk now.Please check.TKS.

comment:4 Changed 7 years ago by plimzy

# svnserve --version
svnserve, version 1.6.17 (r1128011)

compiled Jul 12 2011, 01:57:57

...

# svn -m "test" commit
Adding some.file
Transmitting file data .svn: Commit failed (details follow):
svn: Corrupt node-revision '0.0.t0-a'
svn: Malformed text representation offset line in node-rev

comment:5 in reply to: ↑ 2 Changed 6 years ago by НКВД

Replying to florian:

So how do we fix this problem?

This error is caused by the apr package, which is needed by subversion. I made a patch based on the changes proposed in the message svnserve with corrupt timestamps and malformed text representation in the apache mailing list.

Note: The patch is for the apr package.

diff --git a/include/apr.h.in b/include/apr.h.in
index a411dd0..f9f69cf 100644
--- a/include/apr.h.in
+++ b/include/apr.h.in
@@ -520,10 +520,10 @@ typedef  apr_uint32_t            apr_uintptr_t;
 @size_t_fmt@
 
 /* And APR_OFF_T_FMT */
-@off_t_fmt@
+#define APR_OFF_T_FMT "ld"
 
 /* And APR_PID_T_FMT */
-@pid_t_fmt@
+#define APR_PID_T_FMT "ld"
 
 /* And APR_INT64_T_FMT */
 @int64_t_fmt@
diff --git a/time/unix/time.c b/time/unix/time.c
index dfa45e6..f273beb 100644
--- a/time/unix/time.c
+++ b/time/unix/time.c
@@ -75,7 +75,7 @@ APR_DECLARE(apr_time_t) apr_time_now(void)
 {
     struct timeval tv;
     gettimeofday(&tv, NULL);
-    return tv.tv_sec * APR_USEC_PER_SEC + tv.tv_usec;
+    return tv.tv_sec * (apr_time_t)APR_USEC_PER_SEC + (apr_time_t)tv.tv_usec;
 }
 
 static void explode_time(apr_time_exp_t *xt, apr_time_t t,

comment:6 follow-up: Changed 6 years ago by nico

  • Owner changed from developers to nico
  • Priority changed from normal to response-needed
  • Status changed from new to accepted

Should be fixed in r28760. Since the fix is a bit different (forcing Large File Support in apr), can you confirm this issue is resolved?

comment:7 in reply to: ↑ 6 ; follow-up: Changed 6 years ago by НКВД

Replying to nico:

Should be fixed in r28760. Since the fix is a bit different (forcing Large File Support in apr), can you confirm this issue is resolved?

I have tested the changes done at r28760 but the issue is not gone. Adding the omitted part of the patch proposed at comment:5 (modifications done to include/apr.h.in) into the patch attached at r28760 fixes the issue.

Kind regards.

PS: #10353 is a dupe of this ticket.

comment:8 in reply to: ↑ 7 ; follow-up: Changed 6 years ago by nico

Replying to НКВД:

I have tested the changes done at r28760 but the issue is not gone.

For your test, did your rebuild apr, apr-utils & subversion ?

comment:9 in reply to: ↑ 8 Changed 6 years ago by НКВД

Replying to nico:

Replying to НКВД:

I have tested the changes done at r28760 but the issue is not gone.

For your test, did your rebuild apr, apr-utils & subversion ?

Yes.

comment:10 Changed 6 years ago by nico

  • Resolution set to fixed
  • Status changed from accepted to closed

OK, Large File Support was not passed properly to apr, apr-utils & subversion. If sould be fixed by r28763, r28764 & r28765, thanks for your help!

comment:11 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.