Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9238 closed defect (duplicate)

Changeset 25878 breaks compilation with external ccache program

Reported by: luigi.mantellini@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: toolchain Version: Trunk
Keywords: ccache cmake Cc:

Description

Hi Guys,

I noticed that changset 25878 adds the following to cmake.mk:

...
else

CMAKE_C_COMPILER:=$(STAGING_DIR_HOST)/bin/ccache
CMAKE_C_COMPILER_ARG1:=$(filter-out ccache,$(TARGET_CC))
CMAKE_CXX_COMPILER:=$(STAGING_DIR_HOST)/bin/ccache
CMAKE_CXX_COMPILER_ARG1:=$(filter-out ccache,$(TARGET_CXX))

endif
...

this is wrong because when the host system has a working ccache program, OpenWRT doesn't compile any version into $(STAGING_DIR_HOST)/bin

Solution can be to remove the path from the CMAKE_C_COMPILER and CMAKE_CXX_COMPILER. Alternatively, if we need to have the path,

rules.mk sets the compiler to ccache, assuming the presence in the PATH.

best regards,

luigi

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by veox

Confirmed on r26775.

comment:2 Changed 7 years ago by veox

A workaround is, of course, manually creating a symbolic link to your local ccache. In my case:

ln -s /usr/bin/ccache ./staging_dir/host/bin/ccache

comment:3 Changed 7 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #9611.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.