Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9237 closed defect (worksforme)

Clients with Networkmanager silently lose their wireless connection

Reported by: mk@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: hostapd networkmanager wifi lantiq Cc:

Description

I am using trunk openwrt on an lantiq xway based device.
Wireless is working but after a couple of megabytes transferred the connection to any client using NetworkManager silently drops. There is no output from hostapd (even with -dd) nor in /var/log/daemon.log (networkmanager) in this particular moment.
This is really annoying since I don't have any clue on how to debug this due to the lack of debug output.

I should note that I don't have such a problem when the client uses wpa_supplicant manually to establish the connection.

Attachments (0)

Change History (7)

comment:1 Changed 7 years ago by nbd

What kind of wireless chip does your xway based device have? What driver are you using?

comment:2 Changed 7 years ago by nbd

And which OpenWrt trunk revision?

comment:3 Changed 7 years ago by mk@…

the subtarget is arv4520PW and this particular device has ralink rt61 pci wireless chip

the current version running is "bleeding edge, r26648" from april 11.

comment:4 Changed 7 years ago by anonymous

any hints for debugging this?
the recent hostapd-upgrade did not change this issue

comment:5 Changed 7 years ago by anonymous

I can confirm that

options iwl3945 disable_hw_scan=1

in modprobe.d solves the issue on my notebook with an Intel 3945ABG wifi chip.

comment:6 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.