Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9212 closed defect (invalid)

traceroute -I insists on sending UDP

Reported by: Gustav Schaffter <gustav.schaffter@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Using ATTITUDE ADJUSTMENT (bleeding edge, r26573) on a WNDR3700v2.

traceroute -I <my server on the Internet>
does send UDP packages, even though the -I means to "Use ICMP ECHO instead of UDP datagrams".

root@wndr3700:~# traceroute
BusyBox v1.18.4 (2011-04-08 20:38:24 CEST) multi-call binary.

Usage: traceroute [-FIldnrv] [-f 1ST_TTL] [-m MAXTTL] [-p PORT] [-q PROBES]

[-s SRC_IP] [-t TOS] [-w WAIT_SEC] [-g GATEWAY] [-i IFACE]
[-z PAUSE_MSEC] HOST [BYTES]

Trace the route to HOST

Options:

-F Set the don't fragment bit
-I Use ICMP ECHO instead of UDP datagrams
-l Display the TTL value of the returned packet
-d Set SO_DEBUG options to socket
-n Print numeric addresses
-r Bypass routing tables, send directly to HOST
-v Verbose
-m Max time-to-live (max number of hops)
-p Base UDP port number used in probes

(default 33434)

-q Number of probes per TTL (default 3)
-s IP address to use as the source address
-t Type-of-service in probe packets (default 0)
-w Time in seconds to wait for a response (default 3)
-g Loose source route gateway (8 max)

root@wndr3700:~#

My public external Internet server does let in ICMP messages, but DROP's UDP packages on high ports.

It does fill the log with DROP'ped UDP packages coming from my home public IP on:
# traceroute <my server on the Internet>
which is correct behavior.

It will ALSO fill the log with DROP'ped UDP(!!) packages coming from my home public IP on:
# traceroute -I <my server on the Internet>
which is unexpected behavior.

Oh, and I can:
# ping <my server on the Internet>
from home with success.

If there is any more information I can provide...

GuS

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by Gustav Schaffter <gustav.schaffter@…>

Additional information:

When I use another home computer of mine, running Gentoo Linux, I can use traceroute version 2.0.15 to:

# traceroute -I <my server on the Internet>

I will get a correct trace to my Internet server, since the Internet server will not see any UDP packages and will not DROP any packages. (It's all ICMP traffic, which my Internet server will accept and act upon.)

GuS

comment:2 Changed 7 years ago by Gustav Schaffter <gustav.schaffter@…>

OK, I finally got it. My bad. ;-)

When traceroute is compiled with the BUSYBOX_CONFIG_FEATURE_TRACEROUTE_USE_ICMP=y setting, it will be able to use "ICMP ECHO instead of UDP datagrams" when option -I is given.

I have verified that it works, too. ;-)

This ticket can be closed.
Sorry for the noise.

GuS

comment:3 Changed 7 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

Closed due to user request

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.