Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9202 closed defect (invalid)

Problems installing QoS on TP-Link 1043ND and MR3420: Unable to handle kernel paging

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi, I'm trying to install luci-app-qos on two router (TP-Link 1043ND and MR3420) but I receive always this error:

Configuring iptables-mod-filter.
Configuring kmod-ipt-ipopt.
xt_time: kernel timezone is -0000
Configuring iptables-mod-ipopt.
Configuring kmod-ipt-conntrack-extra.
CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc ==                                                                              8174f028, ra == 801c0eb0
Oops[#1]:
Cpu 0
$ 0   : 00000000 00000000 802d9e00 00000004
$ 4   : 00000000 00000001 80400000 ffffffff
$ 8   : 00000000 80151f10 fff7ffff 00080000
$12   : 00b476fc 00000031 8102d1c0 00b478bc
$16   : 00000000 8040557c 802da010 fffffff5
$20   : 815b6e38 802c0000 00000000 80243ebc
$24   : 00000001 8174f000
$28   : 8166a000 8166bdc8 80243ecc 801c0eb0
Hi    : 00000004
Lo    : 00000000
epc   : 8174f028 0x8174f028
    Not tainted
ra    : 801c0eb0 0x801c0eb0
Status: 1000fc03    KERNEL EXL IE
Cause : 00800008
BadVA : 00000000
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: xt_recent(+) xt_helper xt_conntrack xt_connmark xt_connbytes                                                                              xt_HL xt_hl ipt_ECN xt_CLASSIFY xt_time xt_tcpmss xt_statistic xt_mark xt_length                                                                              xt_DSCP xt_dscp ifb xt_string xt_layer7 ts_fsm ts_bm ts_kmp option usb_wwan ums                                                                             _usbat ums_sddr55 ums_sddr09 ums_karma ums_jumpshot ums_isd200 ums_freecom ums_d                                                                             atafab ums_cypress ums_alauda usbserial ledtrig_usbdev nf_nat_irc nf_conntrack_i                                                                             rc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK ipta                                                                             ble_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_R                                                                             EJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle i                                                                             ptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ntfs ath9k                                                                              ath9k_common ath9k_hw ath mac80211 crc_ccitt cfg80211 compat arc4 aes_generic c                                                                             rypto_algapi usb_storage ehci_hcd sd_mod ext2 ext3 jbd ext4 jbd2 usbcore scsi_mo                                                                             d nls_base mbcache crc16 leds_gpio button_hotplug gpio_buttons input_polldev inp                                                                             ut_core
Process insmod (pid: 1750, threadinfo=8166a000, task=80c6a640, tls=2ae242f0)
Stack : 8040557c 802da010 fffffff5 815b6e38 00000000 801c0eb0 fffffff4 80f65000
        804055f8 81844480 00000001 8040557c 802a0000 802c0000 00000000 801c0fa4
        804055f8 81844480 81042098 c10b8000 81042084 ffffffea 80400000 8174f108
        815b6e38 80290000 00000000 80243ebc 80243ecc 00000000 8174f0a8 800609c0
        81042084 800c72d4 804056b0 804055b0 80290000 804055f8 815b6e38 800916e4
        ...
Call Trace:[<801c0eb0>] 0x801c0eb0
[<802a0000>] 0x802a0000
[<801c0fa4>] 0x801c0fa4
[<80400000>] 0x80400000
[<8174f108>] 0x8174f108
[<8174f0a8>] 0x8174f0a8
[<800609c0>] 0x800609c0
[<800c72d4>] 0x800c72d4
[<800916e4>] 0x800916e4
[<8009f984>] 0x8009f984
[<800691c4>] 0x800691c4


Code: 8c840340  10600003  24050001 <8c850000> 00a3282b  00058036  24630001  0003                                                                             1880  00832021
Disabling lock debugging due to kernel taint
Configuring iptables-mod-conntrack-extra.
Configuring qos-scripts.
Configuring luci-app-qos.

List opkg installed

base-files - 68-r26494
blkid - 1.41.12-1
block-mount - 0.2.0-5
busybox - 1.18.4-1
chat - 2.4.4-16
comgt - 0.32-8
crda - 1.1.1-1
ddns-scripts - 1.0.0-13
dnsmasq - 2.57-1
dropbear - 0.53.1-3
firewall - 2-24
hotplug2 - 1.0-beta-4
iptables - 1.4.10-2
iptables-mod-conntrack - 1.4.10-2
iptables-mod-conntrack-extra - 1.4.10-2
iptables-mod-filter - 1.4.10-2
iptables-mod-ipopt - 1.4.10-2
iptables-mod-nat - 1.4.10-2
iw - 0.9.22-1
kernel - 2.6.37.6-1
kmod-ath - 2.6.37.6+2011-03-24-2
kmod-ath9k - 2.6.37.6+2011-03-24-2
kmod-ath9k-common - 2.6.37.6+2011-03-24-2
kmod-button-hotplug - 2.6.37.6-3
kmod-cfg80211 - 2.6.37.6+2011-03-24-2
kmod-crc-ccitt - 2.6.37.6-1
kmod-crc16 - 2.6.37.6-1
kmod-crypto-aes - 2.6.37.6-1
kmod-crypto-arc4 - 2.6.37.6-1
kmod-crypto-core - 2.6.37.6-1
kmod-fs-ext2 - 2.6.37.6-1
kmod-fs-ext3 - 2.6.37.6-1
kmod-fs-ext4 - 2.6.37.6-1
kmod-fs-mbcache - 2.6.37.6-1
kmod-fs-ntfs - 2.6.37.6-1
kmod-ifb - 2.6.37.6-1
kmod-input-core - 2.6.37.6-1
kmod-input-gpio-buttons - 2.6.37.6-1
kmod-input-polldev - 2.6.37.6-1
kmod-ipt-conntrack - 2.6.37.6-1
kmod-ipt-conntrack-extra - 2.6.37.6-1
kmod-ipt-core - 2.6.37.6-1
kmod-ipt-filter - 2.6.37.6-1
kmod-ipt-ipopt - 2.6.37.6-1
kmod-ipt-nat - 2.6.37.6-1
kmod-ipt-nathelper - 2.6.37.6-1
kmod-leds-gpio - 2.6.37.6-1
kmod-ledtrig-usbdev - 2.6.37.6-1
kmod-mac80211 - 2.6.37.6+2011-03-24-2
kmod-nls-base - 2.6.37.6-1
kmod-ppp - 2.6.37.6-1
kmod-pppoe - 2.6.37.6-1
kmod-sched - 2.6.37.6-1
kmod-scsi-core - 2.6.37.6-1
kmod-textsearch - 2.6.37.6-1
kmod-usb-core - 2.6.37.6-1
kmod-usb-serial - 2.6.37.6-1
kmod-usb-serial-option - 2.6.37.6-1
kmod-usb-serial-wwan - 2.6.37.6-1
kmod-usb-storage - 2.6.37.6-1
kmod-usb-storage-extras - 2.6.37.6-1
kmod-usb2 - 2.6.37.6-1
libblkid - 1.41.12-1
libc - 0.9.32-68
libgcc - linaro-68
libip4tc - 1.4.10-2
libiwinfo - 13
liblua - 5.1.4-7
libnl-tiny - 0.1-2
libuci - 2011-03-27.2-1
libuci-lua - 2011-03-27.2-1
libusb - 0.1.12-2
libuuid - 1.41.12-1
libxtables - 1.4.10-2
lua - 5.1.4-7
luci - 0.10+svn6982-1
luci-app-ddns - 0.10+svn6982-1
luci-app-firewall - 0.10+svn6982-1
luci-app-initmgr - 0.10+svn6982-1
luci-i18n-english - 0.10+svn6982-1
luci-lib-core - 0.10+svn6982-1
luci-lib-ipkg - 0.10+svn6982-1
luci-lib-lmo - 0.10+svn6982-1
luci-lib-nixio - 0.10+svn6982-1
luci-lib-sys - 0.10+svn6982-1
luci-lib-web - 0.10+svn6982-1
luci-mod-admin-core - 0.10+svn6982-1
luci-mod-admin-full - 0.10+svn6982-1
luci-sgi-cgi - 0.10+svn6982-1
luci-theme-base - 0.10+svn6982-1
luci-theme-openwrt - 0.10+svn6982-1
mtd - 15
opkg - 576-1
ppp - 2.4.4-16
ppp-mod-pppoe - 2.4.4-16
qos-scripts - 1.2.1-4
swap-utils - 2.13.0.1-4
swconfig - 7
tc - 2.6.35-3
uci - 2011-03-27.2-1
uhttpd - 22
usb-modeswitch - 1.1.4-1
usb-modeswitch-data - 20100826-1
wireless-tools - 29-4
wpad-mini - 20110402-1

Many thanks !

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by anonymous

Sorry I forgot:
Openwrt version r26505

comment:2 Changed 7 years ago by anonymous

I found that the problem is present only when I install qos-scripts on extroot :(

comment:3 Changed 7 years ago by anonymous

Fixed !
Thanks to this wiki
http://wiki.openwrt.org/doc/howto/extroot?s

Please close this ticket ;)

comment:4 Changed 7 years ago by loswillios

  • Resolution set to invalid
  • Status changed from new to closed

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.