Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9195 closed defect (duplicate)

libmysql crt1.o

Reported by: Nicolas Le Falher <n.lefalher@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: libmysql Cc:

Description

Error with crt1.o when compile libmysql.

#build_dir/target-i386_uClibc-0.9.32/mysql-5.1.53/libmysql$ /bin/bash ../libtool --preserve-dup-deps --tag=CC   --mode=link gcc -fno-stack-protector -L/data/Documents/informatique/Openwrt/src/trunk/staging_dir/target-i386_uClibc-0.9.32/usr/lib -L/data/Documents/informatique/Openwrt/src/trunk/staging_dir/target-i386_uClibc-0.9.32/lib -L/data/Documents/informatique/Openwrt/src/trunk/staging_dir/toolchain-i386_gcc-linaro_uClibc-0.9.32/usr/lib -L/data/Documents/informatique/Openwrt/src/trunk/staging_dir/toolchain-i386_gcc-linaro_uClibc-0.9.32/lib -rdynamic -o conf_to_src conf_to_src.o
libtool: link: gcc -fno-stack-protector -rdynamic -o conf_to_src conf_to_src.o  -L/data/Documents/informatique/Openwrt/src/trunk/staging_dir/target-i386_uClibc-0.9.32/usr/lib -L/data/Documents/informatique/Openwrt/src/trunk/staging_dir/target-i386_uClibc-0.9.32/lib -L/data/Documents/informatique/Openwrt/src/trunk/staging_dir/toolchain-i386_gcc-linaro_uClibc-0.9.32/usr/lib -L/data/Documents/informatique/Openwrt/src/trunk/staging_dir/toolchain-i386_gcc-linaro_uClibc-0.9.32/lib
/usr/lib/gcc/i686-linux-gnu/4.4.5/../../../../lib/crt1.o: In function `_start':
(.text+0xc): undefined reference to `__libc_csu_fini'
/usr/lib/gcc/i686-linux-gnu/4.4.5/../../../../lib/crt1.o: In function `_start':
(.text+0x11): undefined reference to `__libc_csu_init'
/usr/lib/gcc/i686-linux-gnu/4.4.5/../../../../lib/crt1.o: In function `_start':
(.text+0x1d): undefined reference to `__libc_start_main'
conf_to_src.o: In function `print_array':
conf_to_src.c:(.text+0x18d): undefined reference to `__ctype_b_loc'
conf_to_src.c:(.text+0x226): undefined reference to `__ctype_b_loc'
conf_to_src.c:(.text+0x349): undefined reference to `__stack_chk_fail'
collect2: ld returned 1 exit status

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Nicolas Le Falher <n.lefalher@…>

Here a workaround :

#cd trunk/build_dir/target-i386_uClibc-0.9.32/mysql-5.1.53/libmysql
#trunk/build_dir/target-i386_uClibc-0.9.32/mysql-5.1.53/libmysql$ cat Makefile | grep CC_VERSION
CC_VERSION = i486-openwrt-linux-uclibc-gcc (Linaro GCC 4.5-2011.02-0) 4.5.2
#trunk/build_dir/target-i386_uClibc-0.9.32/mysql-5.1.53/libmysql$ export PATH=$PATH:~/trunk/staging_dir/toolchain-i386_gcc-linaro_uClibc-0.9.32/bin/
#make

And its compile, you can make your complete compilation after.

comment:2 Changed 7 years ago by hauke

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #8342

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.