Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9163 closed defect (worksforme)

ath9k: ad-hoc mode not aworking

Reported by: filipebteixeira@… Owned by: developers
Priority: normal Milestone: Backfire 10.03.1
Component: kernel Version: Backfire 10.03
Keywords: Cc:

Description

I built backfire r26383 and installed it on a Ubiquiti Routerstation Pro with a Mikrotik R52n abgn card.

I noticed that after creating an ad-hoc network from luci interface on .11g channels, the network is broadcasted but if I try to connect a windows or linux computer, the client is never able to connect to the network. It only works with another Routerstaion Pro, with the same SW version. On .11a channels, the network isn't broadcasted.

iwconfig:
wlan0 IEEE 802.11abgn ESSID:"ath9k"

Mode:Ad-Hoc Frequency:5.24 GHz Cell: EA:FB:EA:E0:A7:DD
Tx-Power=17 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

/etc/conf/wireless:
config 'wifi-device' 'radio0'

option 'type' 'mac80211'
option 'macaddr' '00:0c:42:66:97:59'
list 'ht_capab' 'SHORT-GI-40'
list 'ht_capab' 'TX-STBC'
list 'ht_capab' 'RX-STBC1'
list 'ht_capab' 'DSSS_CCK-40'
option 'disabled' '0'
option 'txpower' '17'
option 'hwmode' '11a'
option 'country' 'PT'
option 'channel' '48'

config 'wifi-iface'

option 'device' 'radio0'
option 'network' 'lan'
option 'encryption' 'none'
option 'ssid' 'ath9k'
option 'mode' 'adhoc'

Attachments (0)

Change History (11)

comment:1 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r26395, r26396

comment:2 Changed 7 years ago by filipebteixeira@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

The problem is solved on 2.4 Ghz - windows / linux clients can now connect to the ad-hoc network.

However, on 5 Ghz, even if the network is now broadcasted, both windows 7 and ubuntu 10.04 clients cannot connect to the network (even assigning a fixed IP). The configuration is the same as above.

comment:3 Changed 7 years ago by filipebteixeira

madwifi driver (with another atheros card) has the same problem reported in the beginning: ad-hoc network is not broadcasted on 5 Ghz channels

comment:4 Changed 7 years ago by nbd

What do you mean by 'cannot connect to the network'? Ad-Hoc networks do not use any form of association or handshake. Does it appear connected but no data can be transferred?

comment:5 Changed 7 years ago by filipebteixeira

I mean that the node cannot join the ad-hoc network. It fails when trying to join the network

comment:6 Changed 7 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

Then that's not a bug in OpenWrt. An unencrypted Ad-Hoc node cannot refuse the joining of another node. Maybe the passive scan or no-ibss flag is set in the regulatory settings of your client, there's nothing the OpenWrt device can do about that.

comment:7 Changed 7 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

The thing is, at 2.4 Ghz it works fine after your fix. 5 Ghz not, and there is no reason for that.

comment:8 Changed 7 years ago by anonymous

(the network is not even broadcasted using madwifi at 5 Ghz).

comment:9 Changed 7 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

Erm... did you actually read what I wrote? I gave you a reason why 5 GHz might not work.
You wrote earlier that the 5 GHz network is now broadcasted (which means that the underlying issue is fixed).

If your Ubuntu/Win7 devices cannot join then that's clearly an issue with the software on those devices, as the OpenWrt node running the network *cannot* refuse the new incoming nodes.

comment:10 Changed 7 years ago by anonymous

Yes, i wrote. But it is broadcasting only using ath9k only, not madwifi driver.

comment:11 Changed 7 years ago by nbd

yes, but this ticket is about ath9k and not madwifi.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.