Modify

Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#9147 closed enhancement (fixed)

customize lifetimes in 6to4.sh

Reported by: steelman <stlman@…> Owned by: jow
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hardcoded AdvPreferredLifetime and AdvValidLifetime values are too short to use efficiently with RFC3041/4941 random host identifiers. They become obsolete after just 5 minutes. These values should be configurable.

Attachments (1)

fix-6to4-lifetime.patch (702 bytes) - added by dpmcgee@… 6 years ago.
Read values from 6to4 config section

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by jow

  • Milestone changed from Backfire 10.03.1 to Attitude Adjustment (trunk)
  • Owner changed from developers to jow
  • Priority changed from normal to low
  • Status changed from new to accepted
  • Type changed from defect to enhancement

comment:2 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed with r27650, r27651

comment:3 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

This is either not working as intended, or documented totally wrong. Example with a totally stripped down config:

config interface lan
    # these values matter, which is unexpected...
    option adv_valid_lifetime 3600
    option adv_valid_lifetime 1800

config interface wlan
    # these values matter, which is unexpected...
    option adv_valid_lifetime 3600
    option adv_valid_lifetime 1800

config interface wan6
    proto 6to4
    option adv_interface "lan wlan"
    # these do absolutely nothing at all
    option adv_valid_lifetime 3600
    option adv_valid_lifetime 1800

As documented (http://wiki.openwrt.org/doc/uci/network#protocol.6to4.ipv6-in-ipv4.tunnel), these settings belong in the 6to4 interface config, but don't work. The to-be-attached patch should fix this.

Changed 6 years ago by dpmcgee@…

Read values from 6to4 config section

comment:4 Changed 6 years ago by jow

  • Status changed from reopened to accepted

We should probaby retain both possibilities, as the current (debatable) approach allows specifying an individual lifetime for certain interfaces while a generalized one in the 6to4 interface declaration does not.

comment:5 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

Committed in r28223, r28224

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.