Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#9122 closed defect (invalid)

sip phone wip300 drops a wireless connection on WZR-HP-G300NH after several idle hours.

Reported by: Anton <anton.bugs@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

This is a follow up of the ticket #8343. The phone loses a wifi connection while on idle. The connection comes back after that but it breaks an established sip connection. The original buffalo firmware and The WhiteRussian were working fine.

I recompiled the trunk source with ATH_DEBUG
and reloaded it with debug=0x8001 as it was suggested, but haven't caught the precise moment of the drop yet. Hopefully, the log will give you an idea where the problem is because it has more information now.

I really need to fix the problem because the sip phone has an internal bug too which does not re-initiate the SIP connection after wireless drop (similar, then a wifi router has been power off and on).

Attachments (1)

wip300_r26290.log (3.6 KB) - added by Anton <anton.bugs@…> 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by Anton <anton.bugs@…>

comment:1 Changed 7 years ago by Anton <anton.bugs@…>

I've just got a log where it error says: beacon is officially stuck. Any clue?

Mar 27 12:53:19 OpenWrt daemon.info hostapd: wlan0: STA 00:14:bf:fe:6a:7c WPA:
 group key handshake completed (RSN)                  
Mar 27 12:53:19 OpenWrt daemon.info hostapd: wlan0: STA 00:14:bf:fe:6a:7c WPA:
 received EAPOL-Key 2/2 Group with unexpected replay c
Mar 27 12:53:32 OpenWrt kern.debug kernel: ath: Possible baseband hang, busy=32 (try 1)                                             
Mar 27 12:53:35 OpenWrt kern.debug kernel: ath: Possible baseband hang, busy=18 (try 1)                                             
Mar 27 12:53:35 OpenWrt kern.debug kernel: ath: Possible baseband hang, busy=56 (try 1)                                             
Mar 27 12:53:37 OpenWrt kern.debug kernel: ath: Possible baseband hang, busy=33 (try 1)                                             
Mar 27 12:53:40 OpenWrt kern.debug kernel: ath: Possible baseband hang, busy=22 (try 1)                                             
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: missed 1 consecutive beacons                                                        
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: missed 2 consecutive beacons                                                        
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: missed 3 consecutive beacons                                                        
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: missed 4 consecutive beacons                                                        
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: missed 5 consecutive beacons                                                        
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: missed 6 consecutive beacons                                                        
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: missed 7 consecutive beacons                                                        
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: missed 8 consecutive beacons                                                        
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: Possible baseband hang, busy=99 (try 1)                                             
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: beacon is officially stuck                                                          
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: ah->misc_mode 0xc                                                                   
Mar 27 12:53:42 OpenWrt kern.debug kernel: ath: Setting CFG 0x10a                                                                   
Mar 27 12:53:49 OpenWrt kern.debug kernel: ath: Possible baseband hang, busy=23 (try 1)                                             
Mar 27 12:54:15 OpenWrt kern.debug kernel: ath: Possible baseband hang, busy=-1 (try 1)                                             
Mar 27 12:54:16 OpenWrt kern.debug kernel: ath: Possible baseband hang, busy=22 (try 1)

comment:2 Changed 7 years ago by nbd

It looks like the channel your device is on is quite busy. Have you tried switching to another one? When you try one, it should be at least 20 mhz away from this channel.

comment:3 Changed 7 years ago by Anton <anton.bugs@…>

Hm, not really busy, just 2 more low signal AP. Anyway, I've switched from 11 to channel 4 where no AP at all and the signal is the lowest from my neighbors (I've found it using WiFi Analyzer/HTC/Android). The "missed beacon" and "possible baseband hang" errors are still there.

comment:4 Changed 7 years ago by nbd

Scan results are not really a good indication of channel utilization.

Please do this:

rmmod ath9k
insmod ath9k
ifconfig wlan0 up
iw wlan0 scan > /dev/null
iw wlan0 survey dump

And paste the output here.

comment:5 Changed 7 years ago by nbd

Also, did you compare stability against another AP on the same frequency? Because in the log it looks like a sudden burst of interference which disrupts beacon transmission and locks up the hardware.

comment:6 Changed 7 years ago by Anton <anton.bugs@…>

Sorry, I don't have an another AP. I'll try to get one or flash my buffalo with the original firmware. I'm sure it was working fine.
Here is the dump:

Survey data from wlan0

frequency: 2412 MHz [in use]
noise: -92 dBm
channel active time: 94 ms
channel busy time: 20 ms
channel receive time: 14 ms
channel transmit time: 1 ms

Survey data from wlan0

frequency: 2417 MHz
noise: -92 dBm
channel active time: 58 ms
channel busy time: 10 ms
channel receive time: 9 ms
channel transmit time: 0 ms

Survey data from wlan0

frequency: 2422 MHz
noise: -92 dBm
channel active time: 58 ms
channel busy time: 11 ms
channel receive time: 10 ms
channel transmit time: 0 ms

Survey data from wlan0

frequency: 2427 MHz
noise: -93 dBm
channel active time: 58 ms
channel busy time: 13 ms
channel receive time: 12 ms
channel transmit time: 0 ms

Survey data from wlan0

frequency: 2432 MHz
noise: -92 dBm
channel active time: 58 ms
channel busy time: 7 ms
channel receive time: 6 ms
channel transmit time: 1 ms

Survey data from wlan0

frequency: 2437 MHz
noise: -92 dBm
channel active time: 58 ms
channel busy time: 12 ms
channel receive time: 10 ms
channel transmit time: 1 ms

Survey data from wlan0

frequency: 2442 MHz
noise: -93 dBm
channel active time: 58 ms
channel busy time: 9 ms
channel receive time: 7 ms
channel transmit time: 1 ms

Survey data from wlan0

frequency: 2447 MHz
noise: -93 dBm
channel active time: 58 ms
channel busy time: 10 ms
channel receive time: 7 ms
channel transmit time: 1 ms

Survey data from wlan0

frequency: 2452 MHz
noise: -93 dBm
channel active time: 58 ms
channel busy time: 10 ms
channel receive time: 8 ms
channel transmit time: 0 ms

Survey data from wlan0

frequency: 2457 MHz
noise: -93 dBm
channel active time: 58 ms
channel busy time: 5 ms
channel receive time: 4 ms
channel transmit time: 1 ms

Survey data from wlan0

frequency: 2462 MHz
noise: -93 dBm
channel active time: 58 ms
channel busy time: 9 ms
channel receive time: 7 ms
channel transmit time: 1 ms

Survey data from wlan0

frequency: 2467 MHz

Survey data from wlan0

frequency: 2472 MHz

Survey data from wlan0

frequency: 2484 MHz

comment:7 Changed 7 years ago by nbd

Have you double-checked with the original firmware yet?

comment:8 Changed 7 years ago by Anton <anton.bugs@…>

Yes, I've installed the original firmware and the bug seems still the same.
I guess you are right, it's either a busy channel or my custom firewall settings.

Please mark the bug as an invalid for now.

Once again, thank you for your patience and great support.

comment:9 Changed 7 years ago by nbd

  • Resolution set to invalid
  • Status changed from new to closed

OK. Thanks for testing.

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.