Modify

Opened 7 years ago

Closed 7 years ago

#9120 closed defect (invalid)

[x86][backfire] dhcp server doesn't answer

Reported by: flux Owned by: developers
Priority: normal Milestone:
Component: packages Version: Backfire 10.03.1 RC4
Keywords: Cc:

Description

I've compiled the backfire (Backfire (10.03, r26291)) and now dhcp server doesn't work any longer. Client request do reach the router but server never answers

root@Alix:~# tcpdump -i br-lan -n port 67 or port 68
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on br-lan, link-type EN10MB (Ethernet), capture size 96 bytes
15:48:59.219392 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:12:34:56:78:90, length 300
15:49:02.219214 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:12:34:56:78:90, length 300
15:49:10.218047 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:12:34:56:78:90, length 300
15:49:26.215577 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:12:34:56:78:90, length 300
15:49:51.846199 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:12:34:56:78:90, length 300

I haven't changed any configuration file since last build so the settings are the same

root@Alix:~# cat /etc/config/dhcp 

config 'dnsmasq'
        option 'domainneeded' '1'
        option 'boguspriv' '1'
        option 'filterwin2k' '0'
        option 'localise_queries' '1'
        option 'rebind_protection' '1'
        option 'rebind_localhost' '1'
        option 'local' '/lan/'
        option 'domain' 'lan'
        option 'expandhosts' '1'
        option 'nonegcache' '0'
        option 'authoritative' '1'
        option 'readethers' '1'
        option 'leasefile' '/tmp/dhcp.leases'
        option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'
        option 'interface' 'lan'
        option 'start' '100'
        option 'limit' '150'
        option 'leasetime' '12h'

config 'dhcp' 'wan'
        option 'interface' 'wan'
        option 'ignore' '1'

config 'host'
        option 'name' 'notik'
        option 'mac' '00:12:34:56:78:90'
        option 'ip' '192.168.0.150'

config 'host'
        option 'name' 'flux-home'
        option 'mac' '00:18:f3:8f:f5:57'
        option 'ip' '192.168.0.100'

config 'host'
        option 'name' 'wgt'
        option 'mac' '00:09:5b:d1:35:5c'
        option 'ip' '192.168.0.250'

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by flux

For some reason wireless iface lost its association with the lan iface that's why dhcp didn't work. Restoring the setting solves the problem. Shall be closed, sorry for spam

comment:2 Changed 7 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

Closed due to user request

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.