Modify

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#9105 closed defect (fixed)

in pciutils: undefined reference to `__res_query'

Reported by: xuefer@… Owned by: acoul
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

WARNING: skipping pciutils -- package not selected
make[4]: Entering directory `/home/xuefer/src/openwrt-trunk/build_dir/target-i386_eglibc-2.12/pciutils-3.1.7'
/usr/bin/make -C lib all
make[5]: Entering directory `/home/xuefer/src/openwrt-trunk/build_dir/target-i386_eglibc-2.12/pciutils-3.1.7/lib'
make[5]: Nothing to be done for `all'.
make[5]: Leaving directory `/home/xuefer/src/openwrt-trunk/build_dir/target-i386_eglibc-2.12/pciutils-3.1.7/lib'
i486-openwrt-linux-gnu-gcc -L/home/xuefer/src/openwrt-trunk/staging_dir/target-i386_eglibc-2.12/usr/lib -L/home/xuefer/src/openwrt-trunk/staging_dir/target-i386_eglibc-2.12/lib -L/home/xuefer/src/openwrt-trunk/staging_dir/toolchain-i386_gcc-4.5.2_eglibc-2.12/usr/lib -L/home/xuefer/src/openwrt-trunk/staging_dir/toolchain-i386_gcc-4.5.2_eglibc-2.12/lib   lspci.o ls-vpd.o ls-caps.o ls-ecaps.o ls-kernel.o ls-tree.o ls-map.o common.o lib/libpci.a  -lz  -o lspci
lib/libpci.a(names-net.o): In function `pci_id_net_lookup':
names-net.c:(.text+0x117): undefined reference to `__res_query'
collect2: ld returned 1 exit status
make[4]: *** [lspci] Error 1
make[4]: Leaving directory `/home/xuefer/src/openwrt-trunk/build_dir/target-i386_eglibc-2.12/pciutils-3.1.7'
make[3]: *** [/home/xuefer/src/openwrt-trunk/build_dir/target-i386_eglibc-2.12/pciutils-3.1.7/.built] Error 2

looks like it's caused by [26029].
i have no idea when libresolv is needed and when it's not. lib/configure check it

maybe you don't want dns support? why not pass DOS=no to configure

Attachments (1)

104-resolv.patch (519 bytes) - added by acoul 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by jow

  • Owner changed from developers to acoul
  • Status changed from new to assigned

Changed 7 years ago by acoul

comment:2 Changed 7 years ago by acoul

  • Status changed from assigned to accepted

can you please test the above patch?

comment:3 Changed 4 years ago by xuefer

It's building correctly after 104-resolv.patch (the one in svn). please close this ticket as fixed

comment:4 Changed 4 years ago by acoul

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.